Page 1 of 2 12 LastLast
Results 1 to 10 of 11
  1. #1

    Angry Head gasket or something else?

    So last weekend I decided to take the ski out one last time for the summer before storing it. I went for a ride on my local river, went upstream for about 5 miles maybe parked it for 10 minutes or so and waited for the riverboat to pass. Then I said screw it, I'll take a ride downstream and ended up going further then I really bargained for maybe like 10 miles or so to the closest recreational lake. I saw the gas gauge start dropping so I turned around to head back to the dock. About half way back I started running into some trouble. I had to slow down for some kayakers and as soon as I let off the gas the buzzer went off and it said OIL PRESS and started chugging for a min like it went into LIMP mode but it stopped after like 5 seconds and ran like nothing was wrong so I figured it was probably a fluke seeing as it had done this in the past but only when the engine was cold. I ran it back upstream pretty lightly I mean it wasn't full throttle but it wasn't idle maybe like 30MPH. Got back to the dock and put it on the beach so i could back my trailer in. Came back to the ski to load it and when I put the lanyard on it, it said HI TEMP but started just fine. I loaded it on the trailer talked to a guy at the dock and started strapping it down. When I drained the bilge alot of yogurt came out of the plugs. Pulled it back to the house and inspected the engine bay. Right at the top of the throttle body was a shit ton of oil as well as down further in front of the SC. I figured it came out under pressure from the filter housing. I checked the oil and it was bone dry, so I put some oil in and ran it on the hose to see if i could find the leak but to no avail. nothing out of the filter housing and nothing out of any of the plugs. I looked a little deeper and noticed that there was a lot of melted chocolate in the Coolant reservoir as well as a milky substance coming out of the ride plate when I drained a little out of that. I checked the oil and that was also pretty milky but not as bad as the coolant.

    So bearing all that information from what I know about cars this is pretty indicative of a head gasket failure from an overheat. The science behind these rotax motors is beyond my knowledge and I don't want to pull the head off if it could be something else. I didnt do a compression test on it yet. I would like to do that tomm afternoon after work. As far as the oil leak, do I fix the fluid mixing problem first then tackle the oil leak problem? I'm pretty sure she is done for the season .


  2. #2
    Drewski1126's Avatar
    Join Date
    Jun 2018
    Location
    Galveston Texas
    Posts
    64
    +1
    3
    How many hits on the ski, any mods on it.
    From what your describing it sure sounds like a blown head gasket to me.
    That compression test should confirm the head gasket being blown or not I would think.

  3. #3
    Quote Originally Posted by Drewski1126 View Post
    How many hits on the ski, any mods on it.
    From what your describing it sure sounds like a blown head gasket to me.
    That compression test should confirm the head gasket being blown or not I would think.
    There are no mods on it at all its completely bone stock with 150 hours on it. I bought it used a couple years back with 100 hrs on it. And he had the SC rebuild done at exactly 110 hrs

  4. #4
    gone fishing sucks2bu's Avatar
    Join Date
    Sep 2013
    Location
    miami fl.
    Posts
    444
    +1
    21
    Quote Originally Posted by Zchulski View Post
    There are no mods on it at all its completely bone stock with 150 hours on it. I bought it used a couple years back with 100 hrs on it. And he had the SC rebuild done at exactly 110 hrs
    Could just be the oil cooler has sprung a leak and oil is seeping into the coolant through that.

    First off , do a leakdown or compression test.

    If all checks out with that, barring unforseen engine block or head having some sort of casting flaws the only way oil mixes with water is if oil cooler or water pump seal have sprung leaks. My money would be on the oil cooler.

    I have an oil cooler I'll let go off cheap to help out if thats the problem. Good luck.


  5. #5
    Quote Originally Posted by sucks2bu View Post
    Could just be the oil cooler has sprung a leak and oil is seeping into the coolant through that.

    First off , do a leakdown or compression test.

    If all checks out with that, barring unforseen engine block or head having some sort of casting flaws the only way oil mixes with water is if oil cooler or water pump seal have sprung leaks. My money would be on the oil cooler.

    I have an oil cooler I'll let go off cheap to help out if thats the problem. Good luck.
    ok here are the numbers for the compression test

    Cylinder #1 115 psi
    Cylinder #2 100 PSI
    Cylinder #3 98 PSI

  6. #6
    Drewski1126's Avatar
    Join Date
    Jun 2018
    Location
    Galveston Texas
    Posts
    64
    +1
    3
    I would consider 115 on the low side for acceptable on that engine. The other two are definitely low.
    Iíd pull the head and have a look

  7. #7
    So I took the head off a weekend or 2 ago and figured out it was indeed the head gasket! Cylinder head warped as well, I threw that on the grinder and flattened it out. I decided I am gonna take the whole motor out and replace the piston rings, main bearings, and get a set of supertech valves to throw in the head because the exhaust valves looks pretty rusty. I still haven't found the source of the oil leak though. If I had to guess it would be around the PTO housing but I can't be certain. I don't think the PTO bearing seal would have spewed that much oil over the course of a couple hours but I could be completely wrong! While i'm in the process of rebuilding, are there any suggestions as to anything else I should upgrade or replace while iv got the block tore apart?

  8. #8
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,690
    +1
    37
    Leak test your oil cooler as stated above.

  9. #9
    Quote Originally Posted by Shark View Post
    Leak test your oil cooler as stated above.

    It can't be the oil cooler there's oil spatter all over the throttle body. If it were the oil cooler it should have been contained near the hull at the body of the motor, not at the rear on the top of the motor. Or am I missing something

  10. #10
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,690
    +1
    37
    Quote Originally Posted by Zchulski View Post
    It can't be the oil cooler there's oil spatter all over the throttle body. If it were the oil cooler it should have been contained near the hull at the body of the motor, not at the rear on the top of the motor. Or am I missing something
    I’m thinking it probably got pushed out from the coolant reservoir tank.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB New riva head gasket or new stock head gasket ....
    By rxpredviper in forum Sea Doo Classifieds
    Replies: 6
    Last Post: 11-19-2010, 09:48 PM
  2. Riva Head Gasket or Stock?
    By BoostedH23a1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 07-26-2010, 05:45 PM
  3. Problem with rxt-x 260 or something else
    By rxp1972 in forum 4-Tec Performance
    Replies: 9
    Last Post: 07-20-2010, 11:16 PM
  4. Yamaha GP1300R vs STX15F (or something else)
    By Robbbin in forum Yamaha Open Discussion
    Replies: 1
    Last Post: 07-06-2009, 07:23 PM
  5. 07 RXP issue, prop or sc clutch or something else?
    By blandis in forum 4-Tec Performance
    Replies: 9
    Last Post: 09-08-2007, 06:35 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •