Results 1 to 8 of 8

Thread: New oil leak

  1. #1

    New oil leak

    I found noticed yogurt coming out of the bilge. Pretty indicative of an oil leak I'm just not sure where. I'm hoping somebody here can help narrow it down. I'm pretty sure it's coming from the oil filter housing but I'm not sure. There is a shit ton of oil all over the throttle body and coving the coolant resovoir. Which leads me to believe it's the filter housing but I can't really be sure. If it was leaking from the PTO seal I don't think it would spray all the way up there. I don't think there is an oil cooler on the 4tec stock but I'm not sure. Maybe somebody can point me in the right direction.


  2. #2
    imp0ster's Avatar
    Join Date
    Dec 2011
    Location
    Palm Harbor, FL
    Posts
    5,063
    +1
    681
    check the o-ring on the filter cover and bolt going into it.

  3. #3
    That was going to be the first thing I check as soon as I get home from work! Should I let it run while I check it? Also is there a chance it could be the oil pressure sensor as well. There is oil all over the place but because it's puddled near the throttle body leads me to believe it is spraying from either the filter cover or the oil pressure

  4. #4
    welp bad news on this one. I'm gonna have to put her up for the year. In the time it took me to get to the dock to load the ski up she pissed out all the oil and blew the head gasket I think. There's nothing but yogurt in the coolant reservoir and and the oil is kinda milky colored. looks like i'm gonna have a big job next year.

  5. #5
    PWC Addict lilman573's Avatar
    Join Date
    Feb 2010
    Location
    Central NJ
    Posts
    3,024
    +1
    217
    Quote Originally Posted by Zchulski View Post
    welp bad news on this one. I'm gonna have to put her up for the year. In the time it took me to get to the dock to load the ski up she pissed out all the oil and blew the head gasket I think. There's nothing but yogurt in the coolant reservoir and and the oil is kinda milky colored. looks like i'm gonna have a big job next year.
    I would not let it sit like that. You need to get that milky oil out of there for sure....

  6. +1 by:


  7. #6
    should i drain both the coolant and get the oil out and worry about it come next summer?

  8. #7

    Join Date
    Oct 2009
    Location
    Oliphant, west side of Lake Huron
    Posts
    49
    +1
    1
    You shouldn't have oil and coolant mixed, just looks like that because bilge water mixed with leaked oil. Filter housing is under pressure, a crack (very common) in the o-ring and it will leak and spray like you described. Check them, clean out bilge and you're done. Easiest way to clean bilge is to drain what you can. Then spray 1/2 gallon of varsol all through out inside. They drive it up the road to slosh that around real good. Drain all of that you can then add 1 gallon of water and 1/4 cup Dawn into hull and go for another drive. Drain and rinse. Spotlessly clean and smelling nice. Nothing sucks more than oil in the bilge, you KNOW you'll drop a tool under the motor and it's impossible to get back when you're reaching through an oil slick to get it.

  9. #8
    Quote Originally Posted by Sandpiper View Post
    You shouldn't have oil and coolant mixed, just looks like that because bilge water mixed with leaked oil. Filter housing is under pressure, a crack (very common) in the o-ring and it will leak and spray like you described. Check them, clean out bilge and you're done. Easiest way to clean bilge is to drain what you can. Then spray 1/2 gallon of varsol all through out inside. They drive it up the road to slosh that around real good. Drain all of that you can then add 1 gallon of water and 1/4 cup Dawn into hull and go for another drive. Drain and rinse. Spotlessly clean and smelling nice. Nothing sucks more than oil in the bilge, you KNOW you'll drop a tool under the motor and it's impossible to get back when you're reaching through an oil slick to get it.
    It's definitely a bad head gasket. There is oil and coolant mixed in the oil and in the coolant system not just in the bilge. I ran the engine on the hose and didn't see anything spraying out anywhere. I had to run the engine without oil for a good five miles to get back to my dock and by the time I got back it was yelling at me about high temp

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. SPX 720 New motor leaking alot of oil into crank
    By RotaxRipper in forum 2-Stroke Performance
    Replies: 7
    Last Post: 06-06-2014, 07:56 AM
  2. new kawi 250x oil leak!!!
    By grnkawi in forum Kawasaki Open Discussion
    Replies: 8
    Last Post: 09-17-2008, 08:22 PM
  3. Oil leak
    By mjet in forum 4-Tec Performance
    Replies: 0
    Last Post: 10-02-2006, 11:08 PM
  4. Oil leaking near SC
    By Stretch in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 07-14-2006, 07:37 PM
  5. I might have a oil leak in the RXP
    By Jrsrxp in forum 4-Tec Performance
    Replies: 2
    Last Post: 05-02-2005, 12:25 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •