Results 1 to 3 of 3
  1. #1

    Seadoo SpEEDSTER 150 255 HP TAKES LONG TO GET ANY POWER .HELP PLS

    Hey just recently bought this 255 hp speedster. When I put it in the water it runs like shit for a while. I have to go up and down the pond for 15 mins or more for the super charger to start kicking in . Once the boat starts working right she's fine for the rest of the day I don't understand it . Last time I had her out she wouldn't even idle kept shutting off. But once again when I got her going and drove it for 15 or 20 mins she came to life . Got me stumped. Anyone else have this problem ?


  2. #2
    Boat only has 25 hours also

  3. #3

    Join Date
    May 2005
    Location
    Minneapolis
    Posts
    817
    +1
    33
    might have a leaking intercooler - pull discharge tube and look for water -

    change spark plugs.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 ZXI 1100 takes long to get started
    By atvman in forum Kawasaki PWC Performance (2-stroke)
    Replies: 22
    Last Post: 04-19-2017, 10:36 PM
  2. 2009 Seadoo speedster 150 255 hp trailer weight
    By Cathylongasta in forum Sea Doo Open Discussion
    Replies: 1
    Last Post: 09-19-2016, 09:05 PM
  3. 2007 Speedster 150 hour meter just dropped to "0" any ideas why?
    By nceduc8r in forum Sea Doo Open Discussion
    Replies: 0
    Last Post: 05-28-2014, 09:13 PM
  4. 2009 Sea-Doo Speedster 150 255 HP SCIC (Stock)
    By incognito2428 in forum Sea Doo Sport Boats
    Replies: 7
    Last Post: 08-03-2011, 03:26 PM
  5. taking long to get my parts from riva racing
    By wave15stx in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-13-2007, 09:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •