Results 1 to 2 of 2
  1. #1

    Mph on my digital screen says 8mph only never changes someone help

    I have a 2013 rxtxas260 and my mph is like stuck on 8 mph it does move unless I stop then it might go back to 0 but only when i cut it off does it do it every time could it be my cluster messing up or is there a gps on there that could cuz it not to give me my speed also my lil beep noise stopped working too when you put the key on itís supposed to beep to let you know things it never beeps any more


  2. #2
    I know the early year models like my 05 rxp have the old style spinner on the back. Not sure about yours. Could be the gps in the cluster. Have you made any modifications that might interfere with signal. ?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. help on my digital dash
    By kerryhack in forum Kawasaki How To & FAQs
    Replies: 1
    Last Post: 07-29-2012, 06:56 PM
  2. Popping in on my brothers to say howdy
    By Mpeavler in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 02-16-2012, 06:54 PM
  3. Hit a log at 60 mph on my 09 rxpx, suggestions?
    By 98gsxl951 in forum Sea Doo Open Discussion
    Replies: 13
    Last Post: 07-06-2011, 11:58 AM
  4. 84.8 mph on my big bore GPR!
    By Pistonwash in forum 4-Tec Performance
    Replies: 41
    Last Post: 08-10-2008, 09:53 AM
  5. 60.9 Mph on my RXT BLAHHH!! Can it be my Wear ring?
    By Sosa62 in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 07-31-2007, 10:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •