Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 23
  1. #1

    Running out of Ideas.....

    I've been chasing an issue with a "new to me" 2008 GTI 155 SE. Idles and runs fine on trailer, but will not idle in water and tops out around 3800 rpm.

    So far,

    1. New plugs
    2. Replace and calibrated TPS (due to trouble code)
    3. New injectors
    4. New coil packs. Verified strong fire in all cylinders
    5. Tested/verified fuel pressure
    6. Replaced fuel filters
    7. Inspected and lubed throttle body
    8. Replaced broken clamp on exhaust
    9. Checked compression--125-130 on all cylinders
    10. Removed and inspected airbox for obstructions
    11. Checked fuses and power connections including grounds
    12. Waiting for Idle Bypass Valve--no code but cannot feel/hear the motor run when powered
    13. Ohm/volt tested sensors

    Currently, no codes are present. No warnings displayed.

    Where should I look next?

    a. Can a fuel pump partially fail under load?
    b. Intake Manifold leak?


  2. #2
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,690
    +1
    37
    How’s your pump look? How many hours? Ever been rebuilt?

  3. #3
    Drewski1126's Avatar
    Join Date
    Jun 2018
    Location
    Galveston Texas
    Posts
    62
    +1
    3
    Fresh gas. ?

  4. +1 by:


  5. #4
    Quote Originally Posted by Shark View Post
    How’s your pump look? How many hours? Ever been rebuilt?
    106 hours. I don't have much history on this thing. I'm pretty sure that it has sat for the past 2-3 years.

    I haven't touched the pump, but the wear ring and impeller look ok.

    Could/would the pump limit rpm?
    Last edited by LargeJohn; 09-06-2018 at 06:13 AM. Reason: correction

  6. #5
    Quote Originally Posted by Drewski1126 View Post
    Fresh gas. ?
    Forgot to mention. Emptied out about 2 gallons of cloudy gas, and added 6 gallons of 91.

  7. #6
    Drewski1126's Avatar
    Join Date
    Jun 2018
    Location
    Galveston Texas
    Posts
    62
    +1
    3
    Does it hit the reve limiter pretty easy on the trailer when you hit the throttle real quick.

    You could check the pump bearing to make sure it isnít goin out but I donít think that would be it. There Probly be lots of vibrations if it was.

  8. #7

    Join Date
    Sep 2017
    Location
    London UK
    Posts
    68
    +1
    12
    J pipe leaking filling the hull up with exhaust? try running it without the seat on.

  9. #8
    Quote Originally Posted by Drewski1126 View Post
    Does it hit the reve limiter pretty easy on the trailer when you hit the throttle real quick.

    You could check the pump bearing to make sure it isn’t goin out but I don’t think that would be it. There Probly be lots of vibrations if it was.
    This is my first jet ski, so I'm not completely confident about normal operation and normal sounds, but I haven't noticed any bearing noises or excessive vibration.

    Not sure that I understand the rev limiter.... On the trailer, it seems to hit 5500-6000 rpm pretty easily, but I've been reluctant to push it too hard for too long out of water.

    I've seen some others mention replacing valves. The lack of power and being parked for a couple of years is pushing me that direction also...

  10. +1 by:


  11. #9
    Quote Originally Posted by 711jrp View Post
    J pipe leaking filling the hull up with exhaust? try running it without the seat on.
    I'll take another look at the exhaust and J pipe. When I replaced the main exhaust clamp, I thought it was the culprit, but not so.

  12. #10
    Drewski1126's Avatar
    Join Date
    Jun 2018
    Location
    Galveston Texas
    Posts
    62
    +1
    3

    Running out of Ideas.....

    The 08 155 should have the updated valves if Iím not correct. They stopped putting the sodium filled valves in 07 I believe. Unless itís not the original engine.
    You can check the top edge of the valve and see what they are. Just pop off the valve cover and look at them
    Good valve -75
    Bad-72

    Some where in the printing youíll see those combinations.

    Also make sure you got all that gas out. It will kill performance if thereís any old gas left in there.
    Last edited by Drewski1126; 09-06-2018 at 05:49 PM.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 05' GP1300 Issue came up and I have run out of ideas. Need suggestions
    By yamahasrule in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 08-06-2017, 06:46 PM
  2. 1996 gsx bog with youtube video! running out of ideas...
    By jayp0209 in forum 2-Stroke Performance
    Replies: 1
    Last Post: 05-23-2013, 10:44 PM
  3. Running out of ideas here.
    By Pro-pulsion in forum Kawasaki PWC Performance (2-stroke)
    Replies: 9
    Last Post: 08-08-2009, 07:31 AM
  4. Running out of ideas and patience with 98 GTX RFI
    By Tonic in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 08-13-2007, 02:18 PM
  5. Running out of ideas, any suggestions???
    By Gforce in forum 4-Tec Performance
    Replies: 13
    Last Post: 07-03-2005, 12:46 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •