Results 1 to 5 of 5
  1. #1

    2002 Seadoo gtx 4-tec. overheat due to loss of coolant

    Greetings all.

    Had an issue with my GTX this weekend. The hose clamp that hold the coolant line into the engine broke while riding and drained all the coolant into the hull. The warning sound came on but I was out in open water with my son. I didn't know what the issue was so i tried to dash back into shore but didn't make it. Towards the end it lost thrust. I immediately turned it off and we waited for another boat to pass by and tow us in. Back on shore, it still starts. I fixed the clamp and refilled the coolant. Have not taken it back out yet. Wondering if the loss of thrust meant its dead. Hoping someone had the same issue and can give me some insight.

    We have babied these skis for the last 15 years, hoping this isn't the end of one of them.


  2. #2
    Got Boost? psycho rxp's Avatar
    Join Date
    Jul 2005
    Location
    Port St. Lucie, FL
    Posts
    5,453
    +1
    182
    Quote Originally Posted by rparikian View Post
    Greetings all.

    Had an issue with my GTX this weekend. The hose clamp that hold the coolant line into the engine broke while riding and drained all the coolant into the hull. The warning sound came on but I was out in open water with my son. I didn't know what the issue was so i tried to dash back into shore but didn't make it. Towards the end it lost thrust. I immediately turned it off and we waited for another boat to pass by and tow us in. Back on shore, it still starts. I fixed the clamp and refilled the coolant. Have not taken it back out yet. Wondering if the loss of thrust meant its dead. Hoping someone had the same issue and can give me some insight.

    We have babied these skis for the last 15 years, hoping this isn't the end of one of them.

    It probably just went into limp mode, to try to protect the engine

  3. #3
    Hope that was the case. Wont know until i drop it back in the water int he next week or so.

    Thank you.

  4. #4
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,506
    +1
    1,796
    you can start it from dead cold and run it for 30 seconds without putting much hurt on it to check if a garden hose isn't available. you'll know pretty quick if there was serious problems ( smokey exhaust, clanging etc)

  5. #5
    All good next time out. Was in limp mode. Great design. Thanks for all the comments.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 Seadoo GTX 4-tec trouble starting
    By elmatta in forum Sea Doo Open Discussion
    Replies: 7
    Last Post: 06-02-2014, 06:01 PM
  2. Replies: 1
    Last Post: 11-09-2012, 12:30 PM
  3. FS 2002 Seadoo GTX 4-TEC (CT)
    By elmatta in forum Sea Doo 4Tec Skis
    Replies: 2
    Last Post: 08-27-2012, 02:11 PM
  4. 2002 Seadoo GTX 4-TEC problem
    By elmatta in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-06-2012, 02:42 PM
  5. WTB: 2002 Seadoo GTX 4-TEC non SC impeller stock is fine
    By bullseye9899 in forum Sea Doo Sport Boats
    Replies: 0
    Last Post: 08-28-2011, 09:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •