Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11

    Join Date
    May 2016
    Location
    Manchester UK
    Posts
    63
    +1
    5
    Impeller looks like somebody's been smashing it with a sledgehammer. Perhaps the rope was a red herring - the damage looks very rock-related...

    New impeller and ring installed.

    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_8859.jpg 
Views:	212 
Size:	94.5 KB 
ID:	439362   Click image for larger version. 

Name:	IMG_8858.jpg 
Views:	203 
Size:	94.5 KB 
ID:	439363  

  2. #12
    bill321's Avatar
    Join Date
    Oct 2012
    Location
    Lady Lake, Fl
    Posts
    380
    +1
    56
    So let us know the results.....

  3. #13
    Blackhawk36's Avatar
    Join Date
    Apr 2012
    Location
    Maryland, USA
    Posts
    385
    +1
    35
    That is bad and it is your problem, at least most of it. Like bill321 says. Let us know the results. It will help someone else.

  4. #14
    Most definitely the problem. My buddy got a ski rope wrapped around his impeller at WOT and it bent the blades of the prop as well. Not quite as bad as yours though. That thing's roached.

  5. #15

    Join Date
    May 2016
    Location
    Manchester UK
    Posts
    63
    +1
    5
    Finally got the ski on the water after the impeller replacement.

    New Solas "performance" impeller installed. Only 50.00 more than stock replacement, so why not. Wasn't expecting anything significant and was pleasantly surprised to clock 60mph (2up)

    thanks for your help

  6. +1 by:


  7. #16

    Join Date
    Aug 2018
    Location
    Jax, FL
    Posts
    99
    +1
    3
    *

  8. #17

    Join Date
    Sep 2014
    Location
    Southern middle TN
    Posts
    438
    +1
    153
    Quote Originally Posted by tsf View Post
    Finally got the ski on the water after the impeller replacement.

    New Solas "performance" impeller installed. Only 50.00 more than stock replacement, so why not. Wasn't expecting anything significant and was pleasantly surprised to clock 60mph (2up)

    thanks for your help
    glad to hear you got improvements with Solas. I ordered one for my 130 but have not taken the time to install it yet. I am very close to just going ahead and ordering one for my 155 too.

  9. #18
    Quote Originally Posted by tsf View Post
    Finally got the ski on the water after the impeller replacement.

    New Solas "performance" impeller installed. Only 50.00 more than stock replacement, so why not. Wasn't expecting anything significant and was pleasantly surprised to clock 60mph (2up)

    thanks for your help
    What was your top speed with the stock impeller? Thanks


  10. #19
    TAB686's Avatar
    Join Date
    Apr 2017
    Location
    Pennsylvania
    Posts
    66
    +1
    8
    Quote Originally Posted by tsf View Post
    Finally got the ski on the water after the impeller replacement.

    New Solas "performance" impeller installed. Only 50.00 more than stock replacement, so why not. Wasn't expecting anything significant and was pleasantly surprised to clock 60mph (2up)

    thanks for your help
    What was the pitch on the solas you purchased?
    And was there any different bottom end pull or top end rpms? I'm up to 61 also with a repitch on a factory prop at 7660 rpm. Lost a hair off the line but mid and top are great for that ski. Was about the same as you at 57 stock.


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Seadoo GTI se 155 Top Speed and mods
    By canon714 in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-11-2018, 10:04 PM
  2. 2013 Seadoo GTI SE 155 top speed?
    By alec in forum Sea Doo How To & FAQs
    Replies: 2
    Last Post: 12-03-2017, 10:13 PM
  3. top speed problems
    By seadoo98gsxlimited in forum 2-Stroke Performance
    Replies: 22
    Last Post: 05-15-2010, 10:44 AM
  4. rxt 215 2008 top speed problem
    By thomas loh in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-24-2010, 09:03 AM
  5. GTI 720 top speed????
    By 96Waveventure700 in forum 2-Stroke Performance
    Replies: 12
    Last Post: 07-08-2009, 09:19 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •