Results 1 to 8 of 8
  1. #1

    Carb settings on SL650

    Good Day to all. I am Mark. I haven't been on the board for over 4 years! I just turned 70 and have recently relocated, but still reside in So Cal. Prior to moving, I completely rebuilt my Polaris SL650 which I purchased new in '93. It's repainted (USMC Theme) and everything is like new, in and out.

    After the rebuild, I took it to a local lake and had great difficulty getting it to idle properly and it was very "bogged down" and hesitated during throttle up. (I know those terms are indicative of different problems); anyway, I put it back in storage and just now am trying to get it going. I should mention that I removed the oil injection and have gone to pre mix since that was it's original downfall when an oil line broke and I fried the mag cyl. After this long lead in......

    I just went thru each carb and the pop off's were about 23 when it calls for 10-18. I changed the springs and now they all are at about 17. I have double checked the carb syncs and they are good. In order to get it to idle properly, I have the lows at 3/4 out when the book calls for 1/4 on all 3. It now starts immediately and idles very well. When applying throttle, it does well until 1/2 to 3/4 when it hesitates noticeably. Although the book calls for 7/8, 3/8, 5/8 for the highs, I have them almost twice that right now. This is because I want to be rich and then come down to a good 3/4 throttle +.


    I am starting and briefly running in my garage to try and get it within the ballpark before taking it out again. When I say "briefly", I mean 20 seconds or so. I'm kinda not sure why the lows would have to be wider that recommended, but I don't want to fry anything!!

    Primary question: Am I correct that If it idles well will reasonably accelerate to about 1/2 throttle, my low settings and pop offs are good. If I have difficulty beyond that, I should bring down the highs incrementally and see if that corrects the 3/4+ throttle response. I know that once on the water, I can pull the plugs and read them to assist in my high settings. I am also aware of the basics of piston wash reading.

    I am not looking for top performance!! I re-did the machine for my grandkids and primarily want a fun, safe PWC that is unlikely to burn up from lean settings. I know the new machines are really high tech and fast but I was always pretty pleased with my Polaris. We took it to lake powell every year for quite a long time!!

    Thank You
    Mark
    Murrieta, Ca.

  2. #2
    I'm answering my own thread because I just got back form the lake. To begin, I have three semi related threads open. This one, one on low compression (90-100 on all 3) and a thread on mixed gas.
    -----------------
    4 years ago - all new top end; then sat for 4 years after short run on lake and problems getting the carbs set so it would run even close to normal.

    (within the last 3 months: )
    all 3 carbs cleaned and the individual restrictors drilled out and the return line restrictor inserted. (however, not having a spare jet, I drilled a aluminum rod **slightly larger than the recommended 95 jet size)
    All 3 heads removed and noticed that piston wash showed extremely rich from the runs 4 years prior before storage.
    Carbs set per the book; 1/4 out on all 3 lows and 7/8, 3/8 and 5/8 on the highs mag,c,pto

    Today, on the water:
    1. I let it warm up and took it out. Idles great. Approx 1300 rpm steady. Very sluggish at any throttle attempt. Even feathering the throttle didn't help.
    2. Back to shore, opened up the lows to 1/2. 5 mph back out and marked improvement upon applying throttle from idle. Still hesitation at higher throttle, but would take off intermittently.
    ** felt heads and they were very hot.
    3. Back to shore, opened up the highs about a 1/4-1/2 turn each. Back out and it took off like a rocket at all throttle levels, with an occasional need to feather the throttle a little, once in a while, but generally, I
    was very pleased. I removed the thermostat for the remainder of the day. Ran at a temp that was reasonable via touch.

    I just got back and have not yet checked the exact settings of each jet, but suffice to say the lows are approx double the book and the highs are likewise, open wider than the book. However, it ran very nice at the current settings. I do not know if my slightly "larger" restrictor in the return line can effect these settings or the drilling out of the individual restrictor ports??

    Final judgement from today: It ran about 90% like new. The occasional need to work the throttle a little still needs some fine tuning.

    I will pull the heads tomorrow and take a look at the pistons and post some pics. The plugs were oily and wet after the runs. I ran it at 32:1 today.

    Regarding the Compression. My old gauge showed 90-100 psi on all 3. With a new, relatively expensive name brand, gauge, it still showed 90-100 on all 3. It ran at speeds today that make me question any compression loss??

    Any responses would be appreciated.

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,869
    +1
    2,094
    Quote Originally Posted by ltmark View Post
    ... the individual restrictors drilled out

    ...
    Why?

  4. #4
    There are numerous threads and posts relative to the benefits of installing a restrictor in the main return line and enlarging the individual carb restrictors. Having previously lost a piston due to broken oil injection line, I will do any modification that reduces the chance of engine failure!

    Mark

  5. #5
    This is turning out to be my own little back and forth. Anyway, I removed the heads a few hours after my lake ride. Now, remember that I had to turn the lows and highs out from book settings to get to a pretty good throttle response. However, after removing the heads, there is almost complete wash on the mag, about 70% wash in Center and 50% wash on the PTO. Going to have to think a bit on this. ie., I had to add gas to get good throttle response and excellent acceleration, but the pistons show too much gas is being burned during combustion? I'm also still perplexed about the compression readings. At the end of the day, after all the low and high changes, it ran at speeds and acceleration that was, without doubt, equal to when it was new???

    Mark


  6. #6
    Hi Mark,

    What condition are the carb diaphragms? Mine ran great one year and then sluggish the next. It turned out the diaphragms were distorted, likely from soaking in ethanol gas too long. $15 later it was like new.

    Hope you get this sorted out.

    john

  7. #7
    Thank you johnt365, for your comment.

    I have taken it out several times in the last month. "sometimes", it will take of like a rabbit and rn ike new and then all of a sudden, it boggs as soon as I hit the throttle. The last time out it ran good and then did the bogging and failed to take off. I searched everywhere and ultimately found a "primer" line had come off. I put it back on and it ran pretty good for a bit and then wouldn't go past idle.

    There was one point when to test the bogging, I would pump the primer several times and then it would take off; which would show it was lean; but the pistons read as being very rich.

    Re: pop off. The book says 10-18 psi. however, to get that I had to slightly trim new light silver 60 gr springs or it was 25psi.. That shouldn't have to be?? Although not SL650's, normally, everything I read about PSI pop off always say 32 up to 50psi??

    I just ordered 3 new silver and 3 new black springs and will test again.

    My idle and main jets are new, and original spec. Everything is as original. However, I have the F/A off because it's impossible to adjust jets etc with it on and yes, I do recognize that tuning has to be enriched a bit without the F/A.

    It will idle pretty well on any single engine.

    I'm hoping I "stumble on something".. The fact that it will sometimes take off like a rocket tells me it not primary engine related. Also. I don't want anyone to think, or base their ideas, on what they may perceive as a 25 year old messy engine. It's rebuilt, clean and tidy and to look at, you'd think it was 25 years ago!!

  8. #8
    Hey names Kado I see you have posted a lot and are pretty knowledgeable. Can you help me with my 93 sl 650? Thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Carb settings on a 1.0 top end
    By xplayer2885 in forum Polaris PWC Performance
    Replies: 5
    Last Post: 01-10-2014, 02:15 PM
  2. Need Advice for Carb Settings on virage 2004
    By Kory70 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-08-2012, 10:20 AM
  3. Carb settings on 2001 XL800
    By RossM in forum Yamaha PWC Performance (2-stroke)
    Replies: 5
    Last Post: 03-28-2012, 10:23 AM
  4. Carb settings on Sl 750 ?
    By Puerto-Rico in forum Polaris How To & FAQs
    Replies: 5
    Last Post: 07-20-2010, 04:51 PM
  5. Carb settings on 94 Wave Runner III 700
    By RossM in forum Yamaha Old School Skis
    Replies: 1
    Last Post: 06-03-2010, 06:14 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •