Page 1 of 7 123 ... LastLast
Results 1 to 10 of 67
  1. #1

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71

    Polaris Ficht help

    New to the board and Polaris skis. I bought a 01 Polaris Genesis with a hurt motor. I rebuilt the engine. Starts great but seems to be packing fuel pressure it something. Put it in the water yesterday and it stumbled when you go to give it throttle. No lights on or nothing. Check for the pressure regulator to see if it had fallen. It was still in place. Plugs are new. Anyone have the part number for them so I can make sure they are correct? On the injectors are the lower ones the feed? Upper ones the return?
    Last edited by Pro8secondlx; 08-15-2018 at 08:09 AM.


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,402
    +1
    1,880
    Quote Originally Posted by Pro8secondlx View Post
    New to the board and Polaris skis. I bought a 2001 Polaris Genesis with a hurt motor. I rebuilt the engine. Starts great but seems to be packing fuel pressure it something.

    Put it in the water yesterday and it stumbled when you go to give it throttle. No lights on or nothing.

    Check for the pressure regulator to see if it had fallen. It was still in place.

    Plugs are new. Anyone have the part number for them so I can make sure they are correct? On the injectors are the lower ones the feed? Upper ones the return?
    Welcome

    I presume you checked the reed valves during the rebuild. Have you checked cylinder compression since rebuilding it?

    Also check the exhaust hoses for signs of overheating. If the engine has previously back fired sometimes that splits the plastic exhaust resonator along a seam. An exhaust leak inside the hull will affect engine power.

    Are you water testing while strapped down to the trailer front and back, backed down the launch ramp? That is the preferred method for initial water testing. You can leave the seat off and monitor the engine area while running it as long as needed. The jet pump will be submerged so the engine will have water flow.

    It should idle at a stable 1150 RPM, hot or cold, in or out of the water.

    All Polaris Ficht engines use NGK spark plugs PZFR6H. Incorrect spark plugs can cause weird running symptoms.

    The engine and exhaust should never get so hot that you cannot touch it. Should be able to put your hand on any part for several seconds without burning your skin.

    Note: Fuel pressure regulator reinforcement is a mandatory repair, even if the stock regulator has not yet fallen out. That said, you can check fuel pressure at the schrader valve on the return fuel hose. Return fuel hose connects to the upper fittings on the fuel injectors. Should rise to a little over 20 PSI, immediately after engine start if not during cranking.

    Tip: Click here for lots more useful info
    http://polarispwcknowledge.shorturl....t-things-to-do





  3. #3

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71
    I put the ski in the water , took it off the trailer. When you first give it throttle it want to go for a few seconds then it acts like it Miss's I let off it then. At idle it's perfect.
    Last edited by Pro8secondlx; 08-13-2018 at 10:42 AM.

  4. #4

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71
    I'm going to check the fuel pressure this evening. So the supply from the pump goes to the bottom fitting on the injector. Top goes back to the tank unit. Schrader valve one goes in the return line side?

  5. #5

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71
    Plug gap?

  6. #6
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    938
    +1
    98
    Quote Originally Posted by Pro8secondlx View Post
    I'm going to check the fuel pressure this evening. So the supply from the pump goes to the bottom fitting on the injector. Top goes back to the tank unit. Schrader valve one goes in the return line side?
    Correct. Plug gap info is here, ignore the warning.

  7. #7

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71
    Correct plugs . Fuel pressure running was 20 clamp return off goes to 35 or so
    Last edited by Pro8secondlx; 08-13-2018 at 03:36 PM.

  8. #8

    Join Date
    Jul 2018
    Location
    Gloucester Va
    Posts
    71
    Could the TPS cause the bogging and engine miss when you take off

  9. #9
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    938
    +1
    98
    Does the fuel pressure remain at 20 psi + when in the failure mode?

    Where are you located?

  10. #10
    martincom's Avatar
    Join Date
    May 2010
    Location
    Brainerd, MN
    Posts
    938
    +1
    98
    Is it missing and/or backfiring?

Page 1 of 7 123 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Buying 95 Polaris 750slt help please!!!
    By mboley in forum Polaris Open Discussion
    Replies: 28
    Last Post: 01-27-2010, 09:21 PM
  2. 2001 polaris virage help please
    By h23pasadena23 in forum Polaris Open Discussion
    Replies: 22
    Last Post: 03-19-2008, 10:32 AM
  3. 1996 polaris 700 HELP!!
    By jsc7002 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 07-31-2007, 02:28 PM
  4. new to polaris need help please
    By pepp101 in forum Polaris Projects
    Replies: 22
    Last Post: 07-30-2007, 02:15 PM
  5. 1994 Polaris 750 Help ASAP
    By sgshore in forum Polaris PWC Performance
    Replies: 6
    Last Post: 04-15-2007, 11:13 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •