Page 1 of 2 1 2 LastLast
Results 1 to 10 of 20
  1. #1

    2010 Ultra LX crank wheel help

    Hi there I have a 2010 Ultra LX with the 1500cc engine (NA) now I want to know if anyone can tell me what wheel the crank sensor should have if it is a 8 tooth or the 24-2 one??? I been told it should have the 24-2 as it runs the 260 bottom end. Is there anyone who can definatly tell me what one it should have???

  2. #2

    Join Date
    Aug 2017
    Posts
    236
    +1
    19


    Looks like that motor uses the 21007-A reluctor wheel (which looks like a 24 tooth), part # 21007-3744

    https://www.kawasakipartshouse.com/o...gnition-system

  3. #3

    Join Date
    Aug 2015
    Location
    Ct.
    Posts
    316
    +1
    33
    To the OP. I see there are many threads on this and NMPeter(forgive me if I botched the screen name) in the other thread is trying to help you. You could have had this new part for 14 bucks, heck even could have bought one of each for all the time and energy and money you are wasting on here by posting in many subforums. I am not a fan of throwing parts at something though, but this is cheap enough compared to an ecm. If you have a multimeter I am sure there is a way to see if you are getting a pulse output from this set up. It is just a flying magnet/trigger/stator/PIP pulse generator.

  4. #4
    Quote Originally Posted by TJS0712F View Post
    To the OP. I see there are many threads on this and NMPeter(forgive me if I botched the screen name) in the other thread is trying to help you. You could have had this new part for 14 bucks, heck even could have bought one of each for all the time and energy and money you are wasting on here by posting in many subforums. I am not a fan of throwing parts at something though, but this is cheap enough compared to an ecm. If you have a multimeter I am sure there is a way to see if you are getting a pulse output from this set up. It is just a flying magnet/trigger/stator/PIP pulse generator.
    Hi TJS0712F, Yes i could of had it fixed but i could of also replaced a million parts as everyone has gave their input so i am testing and making sure it is correct before i go buy the parts and that is why it is still going. I have finally think i have found th issue and as said bove it should have the opposite one to what i have got so its looking good. GOd if i replacd what i have been told i would have a brand new ski, Yes i have had some good support and help but i am also not shotgunning and replacing what everyone says otherwise i would of had a new harness, ECU, coils, reluctor, stator, Crank sensor, cam sensor, roll over sensor....... so i check if they are ok and in service beofre i go replace.

    Yes i am getting a pulse from it and would as it would still pas past the pickup but it may not be the correct signal or enough. But like above i person said it should going by the service manual have the multi tooth one but mine doesnt. I know it should by the manual but is the manual correct is what i ned to know hence why i am asking here!!!!!!

  5. #5
    Quote Originally Posted by pops View Post


    Looks like that motor uses the 21007-A reluctor wheel (which looks like a 24 tooth), part # 21007-3744

    https://www.kawasakipartshouse.com/o...gnition-system

    Thanks Pops thats why i am asking as i seen that in the manual and mine has the 8 tooth one so i am wanting to know is my ski wrong or is the manual wrong.
    Thank you.

  6. #6
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,449
    +1
    1,770
    when you deal with a ski that didn't run when you bought it and the seller is an obvious liar, you need to be ready for anything.

    to see what yours might look like scour for some pictures on ebay or on the web in general.

    that's how the wrong puller bit was detected on the other fellows kawasaki ( off time spark)

    the trigger wheel, cam sensor and ecu must all be from the same model.

    the error code can be misleading due to translation issues.

    could be "so far off time I won't even bother to spark"

    any difference when you pulled the coils?

  7. #7

    Join Date
    Aug 2017
    Posts
    236
    +1
    19
    Quote Originally Posted by SEDUCE View Post
    Thanks Pops thats why i am asking as i seen that in the manual and mine has the 8 tooth one so i am wanting to know is my ski wrong or is the manual wrong.
    Thank you.
    The big problem I see is that most think a 1.5L is a 1.5L. They are, BUT the electronics need to all be the same, ECU, sensors and such. A 15f engine is pretty much the same as the LX engine, but the electronics and mechanical sensor reluctors are different.

  8. #8
    JTT50AE031870 is engine number is that original engine anyone know??

  9. #9
    Quote Originally Posted by nmpeter View Post
    when you deal with a ski that didn't run when you bought it and the seller is an obvious liar, you need to be ready for anything.

    to see what yours might look like scour for some pictures on ebay or on the web in general.

    that's how the wrong puller bit was detected on the other fellows kawasaki ( off time spark)

    the trigger wheel, cam sensor and ecu must all be from the same model.

    the error code can be misleading due to translation issues.

    could be "so far off time I won't even bother to spark"

    any difference when you pulled the coils?
    What do you mean any difference when pulled coils??? i can not get spark at all have tried every thing and no spark.
    I rang a kawasaki dealer from the next city and he knew straight up i asked him does the 2010 model ultra lx have for a crank shaft sensor rotor wheel and he replied 24 straight up so i guess mine is wrong. Also can anyone tell me how do i tell what engine i have i guess i have attached engine number so how do i tell if it is genuine engine ?????


  10. #10
    Just found out it is actually a 2008 model not 2010 like I was told.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB - Parts 2007 Ultra LX timing wheel cut to 5 or 6 degrees
    By Livin on the Edge in forum Kawasaki Classifieds
    Replies: 3
    Last Post: 01-13-2018, 04:26 PM
  2. 2010 ultra lx no fuel
    By hugedog897 in forum Kawasaki How To & FAQs
    Replies: 23
    Last Post: 12-28-2015, 01:02 AM
  3. Hot start problem with 2010 Ultra LX
    By Tony R in forum Kawasaki PWC Performance (4-stroke)
    Replies: 25
    Last Post: 09-07-2014, 05:37 PM
  4. Replacing the damper on front hatch - 2010 Ultra LX
    By Tony R in forum Kawasaki PWC Performance (4-stroke)
    Replies: 7
    Last Post: 01-28-2013, 05:04 AM
  5. 07 Ultra LX - Hoses melting HELP!!
    By Jon6683 in forum Kawasaki Open Discussion
    Replies: 12
    Last Post: 06-01-2010, 11:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •