Results 1 to 10 of 10
  1. #1

    1100 zxi filling hull with water fast

    So I took my ski out yesterday to test my new sponsons and after 15 mins the ski was running really odd and felt heavy, pulled off the seat and water was up to the cdi box, pulled on shore to pull the plug and drained it, road 5 mins straight back to the landing and was about a 3rd as full as last time. Water seems to be entering at a good 3gallons+ a minute and I have no idea where or how. I can not see anything on the hull and when I ran it on the hose at home there werr no leaks, all coolant hoses are on and in there correct positions. Ski is currently in my garage with the cdi box open to dry out, attached is a pic of the only thing I could find and it shouldent matter due to the location I thought as far as being able to get water in the hull, only other thing is the one air induction hull plate is now completely broken off and I covered it almost completely with a plastic piece with a little room to mimic a plate untill I do a real fix. Could this of caused a pressure difference forcefully sucking water in the hull from the other side?
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	20180805_193928.jpg 
Views:	139 
Size:	26.4 KB 
ID:	437744  

  2. #2
    jakber's Avatar
    Join Date
    Oct 2017
    Location
    lake travis texas
    Posts
    175
    +1
    2
    Check your through hull seals and check your pisser lines, those are common and can sink a ski fast

  3. #3
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,985
    +1
    678
    Driveshaft seal, (bearing holder).

  4. #4
    DavidR's Avatar
    Join Date
    Jul 2013
    Location
    Forney,Tx
    Posts
    799
    +1
    44
    The through hull seal is the most likely culprit as it won't show up while running it on the hose. Coolant line leaks, rotted out exhaust manifold, holes in muffler should show up on the hose. Air induction.....maybe, if the part that comes through the hull is is damaged, but that should show up just sitting in the water. Now, if the hole was left un-covered it would force water up the tube and into the hull at speed. You should be able to check inside the rubber tube to see if it's wet. Riding it with the seat off for a minute should show you the problem.

    That silicone coming off the pump shoe in your picture isn't your problem.

  5. #5
    Quote Originally Posted by DavidR View Post
    The through hull seal is the most likely culprit as it won't show up while running it on the hose. Coolant line leaks, rotted out exhaust manifold, holes in muffler should show up on the hose. Air induction.....maybe, if the part that comes through the hull is is damaged, but that should show up just sitting in the water. Now, if the hole was left un-covered it would force water up the tube and into the hull at speed. You should be able to check inside the rubber tube to see if it's wet. Riding it with the seat off for a minute should show you the problem.

    That silicone coming off the pump shoe in your picture isn't your problem.
    Exactly my thought as far as riding eitht he seat off and checking the tube! I was going to take it to the river yesterday but it was raining so I will be doing this today. I will update with results

  6. #6
    Its the air induction! Rode with the seat off and after 30+ mph water was comming out of the right side hose. Removed the crappy temporary plastic plate and tape fix I made so it wad just the hole and at 30+ water was comming in like a fire hose! Time to make a new plate unless someone has 14090-3788 (ram cover rh) laying around or knows somewhere that sells it and is not out of stock (most places say they have it but when ordered it doesent go trough or never ships untill i call them and they give me the bad news)

  7. #7
    steve45's Avatar
    Join Date
    Feb 2008
    Location
    Texas
    Posts
    6,985
    +1
    678
    Have you checked the GreenHulk OEM parts store? If they don't have it, Partzilla is showing 4-day delivery.

  8. #8
    DavidR's Avatar
    Join Date
    Jul 2013
    Location
    Forney,Tx
    Posts
    799
    +1
    44
    You could message one of the eBay sellers that is parting one out and see if they have one and will sell it to you. Get the bolt and washers too.


  9. #9
    DavidR's Avatar
    Join Date
    Jul 2013
    Location
    Forney,Tx
    Posts
    799
    +1
    44

  10. #10
    Thanks! I sent him a PM.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 1998 GTX Hull Filled Partially With Water -Questions
    By msd58 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 09-11-2015, 04:45 PM
  2. 2006 rxp filling hull with water
    By missrxp in forum 4-Tec Performance
    Replies: 6
    Last Post: 09-03-2012, 08:14 PM
  3. 2006 Kawasaki STX 15 F filling up with water...need help
    By venomus94 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 12
    Last Post: 07-04-2010, 09:41 PM
  4. ultra 150 hull filling up with water why
    By kaotic racing in forum Kawasaki Open Discussion
    Replies: 7
    Last Post: 11-10-2008, 03:56 PM
  5. Hull filling up with water?
    By silvervette97 in forum Yamaha Old School Skis
    Replies: 6
    Last Post: 09-03-2007, 12:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •