Page 1 of 2 12 LastLast
Results 1 to 10 of 14
  1. #1

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7

    Post 2004 GTX SC 185 Maxing Out at About 6800 RPMs...why?

    Hi, new to the forum:

    First ski I've owned. Bought last year with 94 hours on it. Previous owner had just replaced supercharger (no ceramic washers), installed RIVA air intake, and installed stainless steel impeller.

    Last year after purchasing, ski ran great and reached 7300-7400 RPMs. Added about 50 hours on it during season.

    This year after winter, I did oil change, replaced spark plugs, and coolant flush. First ride this season, the ski only reached 6800-7000 RPMs.
    I checked oil level during first ride, noticed it was too full (just above top bend) so I sucked oil out to get it at middle of two bends. Still only reaches 6800-7000 RPMs. Seems to be running fine otherwise.

    Wear ring has some scratches but no deep gouges. (Picture below)

    I took air intake off SC and tried spinning impeller with fingers, could not do so . I know I should properly check slipping moment but currently don't have special tools required. Planned on sending SC to Jerry after this season for rebuild.

    Should I send it in sooner? What else can I check? Could it be damaged from overfilling oil?


    Any help is appreciated, thank you all!
    -G
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20180730_185008.jpg 
Views:	190 
Size:	70.4 KB 
ID:	437403  


  2. #2
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,414
    +1
    133
    Not that its your problem, but the uneven gap on the impeller nose cone is an area of concern. If its installed all the way into the impeller, there seems to be a misalignment from driveshaft to impeller with the large gap at bottom of nose cone and no gap at top. (engine alignment)

    As it has no intercooler, its not that. Make sure the throttle cable is adjusted correctly WOT its on the stop, yet at idle it returns to the idle stop.
    Boost leak, be sure your SC to intake clamps are tight and sealing.
    Sparkplugs, maybe a defective one, happens. do you still have the old plugs
    Press the SET button 5X, any P codes displayed?

  3. #3

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7
    Hey Splash, thanks for the input!

    The nose cone looks that way because it is freely sliding on the driveshaft (picture below)...previous owner must have not installed correctly. I realize this is a problem but I didn't think it's causing the RPM loss so I'm saving it for another day..

    Using forums I came to similar conclusions and checked the intake clamps (seem pretty tight, can't wiggle/move them).
    I also thought it could've been a plug, and swapped the new with the old ones but no change.
    Just last night I checked the throttle cable, it seems to be fine, full travel...

    I'll check for P codes later but I don't think there are any.

    Anything else I can try?



    Thanks again!
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	IMG_20180730_185339.jpg 
Views:	175 
Size:	76.7 KB 
ID:	437411  

  4. #4

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7
    It's possible the jet pump has never been disassembled & inspected....could this have any effect on RPMs?

  5. #5

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7
    bump

  6. #6
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,023
    +1
    780
    That loose Solas nose cone will have a HUGE impact on performance and cause excess cavitation!

    What pitch impeller did you install because your rpms are obviously way too low? The GTX 185 OEM limiter is 7650, and you should be shooting for 7550-7600 rpm.

    See my signature for our 2005 GTX. You need a 13/18 pitch to get those rpms back up!!!

  7. +1 by:


  8. #7

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7
    Hey jpt,

    The previous owner installed the impeller & nose cone. So I don't know what pitch it is...but even with this impeller last season I was getting higher RPMs, why would it drop in RPMs when nothing has changed.

    I'm reading a lot of mixed opinions about the nose cone. A lot of people are saying to just take it off and run without it. Then I read some people saying to just use the OEM seal.

    Do you have an opinion to fix it?

    Sorry, this is my first ski, trying to find the best option.

    Thanks for your help!
    -G

  9. #8
    I was told on a stock ski the 12 /20 pitch is what I needed.it hooked up better out of the hole,but I lost about 200rpm on top.i might see 1-2 mph faster.im getting ready to send my sc in to jerry,maybe I will see the 200 rpm once I get it back.

  10. #9
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,965
    +1
    2,767
    Quote Originally Posted by Gonads3137 View Post
    Previous owner had just installed stainless steel impeller.
    Which stainless steel impeller? What pitch? If too much pitch it will cause reduced RPM.
    It's also time to change that wear ring... and ditch the nose cone.

  11. #10

    Join Date
    Jul 2018
    Location
    Michigan
    Posts
    7
    Quote Originally Posted by Green Hulk View Post
    Which stainless steel impeller? What pitch? If too much pitch it will cause reduced RPM.
    It's also time to change that wear ring... and ditch the nose cone.
    I'll have to take it out and look for any identifying marks, since it was already on when I purchased ski.
    I'll replace wear ring and lose the nose cone if it's unnecessary.
    I'll also be sending my SC to you soon.

    Thanks for the help Jerry!
    -G

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. does the 2003 gtx sc 185 have the same engine as the 2004 rip 215?
    By toxicgun in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-26-2012, 09:30 PM
  2. 2004 gtx sc 185 4000.00
    By ALOHR in forum Sea Doo 4Tec Skis
    Replies: 3
    Last Post: 02-17-2009, 05:33 PM
  3. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 5
    Last Post: 08-09-2008, 09:14 PM
  4. 2004 GTX SC 185 Stage One Kit
    By poboy74 in forum 4-Tec Performance
    Replies: 6
    Last Post: 08-07-2008, 05:06 PM
  5. 2004 Gtx Sc 185 Hp
    By Gunguy in forum 4-Tec Performance
    Replies: 2
    Last Post: 07-26-2008, 09:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •