Results 1 to 9 of 9
  1. #1

    2010 RXT 260 holding back at WOT the first time

    Hey all,

    when riding on the sea and i wanne go at WOT, the rpm goes max 5000 - 6000 range and a few seconds ( 5 seconds ) later it goes full speed.
    First i thaught that there was something in the propellor but today i had the same problem again...

    once it goes full speed, i have no more problems... its just after riding slow for some time and then going full speed again the problum could re occur...


    could somebody tell me what is going on? i dont think its the SC slipping because i would have more problems then

  2. #2
    Stevie-Ray's Avatar
    Join Date
    May 2017
    Location
    The Shores of Lake Huron
    Posts
    42
    +1
    6
    I had a similar problem a couple days ago in touring mode, which is what I normally leave it in, unless carving corners, doughnuts, S-turns, etc. Mine seemed to bog a bit for a few seconds, then nearly pulled my arms out of my shoulders. Didn't do it again, though. Today it was entirely too rough out and never got over 25, so I couldn't check it again. ???


  3. #3
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,875
    +1
    377
    It's perfectly normal, when you slow down you get alittle condensation in the intercooler. The when you accelerate you pull that little bit of condensation(water) into the motor and you have that momentary stumble.

  4. #4
    Quote Originally Posted by moparguy View Post
    It's perfectly normal, when you slow down you get alittle condensation in the intercooler. The when you accelerate you pull that little bit of condensation(water) into the motor and you have that momentary stumble.
    last year I pulled of the hose at the throttle body, to see if the inter cooler was leaky, when I accelerated a bit of water was coming out. If I had a leaky intercooler, I would not reach top speed no?

  5. #5
    Quote Originally Posted by rinus View Post
    last year I pulled of the hose at the throttle body, to see if the inter cooler was leaky, when I accelerated a bit of water was coming out. If I had a leaky intercooler, I would not reach top speed no?
    Today still got same problem, but it hesitates for longer period (more then 4 seconds ). Maybe ic... I canít remember having this on flat water, I will need to see when I get back home from holidays

  6. #6
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,692
    +1
    40
    I would check your intercooler and your plugs. Also would be good to mention if this doesn’t fix the problem: How many hours on supercharger.

  7. #7
    Quote Originally Posted by Shark View Post
    I would check your intercooler and your plugs. Also would be good to mention if this doesnít fix the problem: How many hours on supercharger.
    when i check the ic, there is a bit of water coming out when I accelerate. Also the rpm at wot goes 7300 at the start and then to 7700-7800 max... spark plugs are new and have 25 hours on it, and the supercharger has had a rebuild 30 hours ago. I donít think there is slip on it.

  8. #8
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    4,100
    +1
    798
    Time for a new IC!

  9. +1 by:


  10. #9
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,692
    +1
    40
    Remove IC and pressure test it

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. RXT 260 2012 - Runs at WOT and Stalls -- PLEASE HELP!!!
    By napadaylodan in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-03-2015, 08:56 AM
  2. Replies: 2
    Last Post: 08-16-2014, 11:04 AM
  3. WTB 2010 RXT 260 venturi nozzle
    By ou812 in forum Sea Doo Classifieds
    Replies: 0
    Last Post: 07-23-2014, 04:33 PM
  4. 2010 RXT 260 7-5K to Build Riva or R&D
    By andreasenracing in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-05-2014, 03:29 PM
  5. 2010 rxt 260 on the water
    By ou812 in forum 4-Tec Performance
    Replies: 26
    Last Post: 02-17-2010, 07:20 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •