Results 1 to 10 of 10

Thread: Fzs misfiring

  1. #1
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    91
    +1
    5

    Fzs misfiring

    I have a 2014 fzs 45 hours riva exhaust,riva fresh air kit,crankcase breather,scom,ribbon delete,and boost gauge it's started having a skip/ misfire this season but not bad and cleared up after an hour or 2 well I took it out this past weekend and it skipped real bad until it warmed up then ran perfect any known issues ? Could it be spark plugs? I only had 1 set of plugs put in since I bought it that was around 10 hours
    Last edited by fun rider; 07-09-2018 at 04:04 AM.

  2. #2
    dixon0001's Avatar
    Join Date
    Aug 2008
    Location
    north east uk (hartlepool)
    Posts
    558
    +1
    25
    Try new set for price they cost

  3. #3
    Take it step by step.Change out the plugs and check the resistance on the coils while you have them out.Then shine a flashlight into the plug hole for any specks of water on the piston tops.If you either see water or the plugs just do not do fix it pull the lower intercooler pipe and check for water.Those are going to be the three most common intermittent misfire causes

  4. #4
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    91
    +1
    5
    Ill give those things a try hopefully it's nothing major

  5. #5
    RIVERA RACING RIVERA RACING's Avatar
    Join Date
    Jan 2010
    Location
    New Jersey
    Posts
    1,721
    +1
    109
    It could be bad fuel....or bad plugs..

  6. #6
    While its on the hose, pull off connector of a coil one at a time. Should run on the 3 cylinders. If you pull one and theres no change maybe that plug. Reconnect and pull another if it stalls then the other was your bad plug. If it keeps running going hrough all four most likely not the plugs

  7. #7
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    91
    +1
    5
    Shouldnt be fuel just filled it up with 93 and these things wont give a engine code for misfire? What gets me is it only does it when I first start it up after sitting for a few hours but after about 2 mins it clears up and runs perfect and strong

  8. #8
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    91
    +1
    5
    Still trying to find plugs apparently nobody around me has them I'll try cycle world tomorrow

  9. #9
    Quote Originally Posted by fun rider View Post
    Still trying to find plugs apparently nobody around me has them I'll try cycle world tomorrow
    Try a Napa store...

  10. #10
    fun rider's Avatar
    Join Date
    Jul 2014
    Location
    hartwell ga
    Posts
    91
    +1
    5
    Forgot to respond back it did end up being spark plugs put a new set in and it runs like a dream appreciate yalls help sry to drag up an old thread found it while doing some searching on aftermarket plugs and intercoolers


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Fz SvHo Misfire........
    By RIVERA RACING in forum Yamaha PWC Performance (4-stroke)
    Replies: 15
    Last Post: 06-09-2016, 07:33 AM
  2. 787 misfire - diagnostic help needed
    By javiert99 in forum 4-Tec Performance
    Replies: 3
    Last Post: 10-22-2006, 02:20 PM
  3. Cylinder 1 Misfire
    By njgprider in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 08-03-2006, 01:52 PM
  4. GP1200R Ltd - front cylinder misfire problem
    By Flywheel in forum Yamaha PWC Performance (2-stroke)
    Replies: 6
    Last Post: 05-18-2006, 10:05 AM
  5. 2001 Yamaha FZ-1
    By Hydrotoys in forum Other Toys
    Replies: 3
    Last Post: 01-31-2006, 03:21 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •