Page 3 of 3 FirstFirst 1 2 3
Results 21 to 25 of 25
  1. #21

    Join Date
    Jul 2015
    Location
    Woburn, MASS
    Posts
    26
    +1
    2
    Quote Originally Posted by 1tommygunner1927 View Post
    Is the flame arrestor still in the intake manifold? If not, how was it removed?

    Consider purchasing the CanDooPro.
    https://www.4-tecperformance.com/ind...oducts_id=2028
    Why does this have relevance? It has not been removed and is still there.

  2. #22

    Join Date
    Jul 2015
    Location
    Woburn, MASS
    Posts
    26
    +1
    2
    I think whats happening here is a I'm down on one or more cylinders just a little bit. It seems to match up with everything I have seen. Are there any articles on leak-down SPECIFICally for 4tecs just to make sure I dont miss anything.

  3. #23
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    7,335
    +1
    1,353
    Quote Originally Posted by bigburd View Post
    Why does this have relevance? It has not been removed and is still there.
    Depending how it was removed, there could be a vacuum leak. Moot point now. Check throttle body to ensure the throttle blade opens completely. Pull charge tube off the TB, plug in key, do not start, using a mirror not fingers, apply full throttle.

  4. #24

    Join Date
    Jun 2016
    Location
    northern nj
    Posts
    49
    Quote Originally Posted by bigburd View Post
    Hi,

    Have a 2010 RXTX starts and runs 50MPH no problem. Changed coils with known working RXP, replaced spark plugs.

    Ski idles rough something is def going on cuz sometimes it dies in the water after startup if you dont give it any gas.

    No check engine light/no codes have hooked it to BRP USB.

    Any ideas? Feels like a vacuum leak on a car.
    figure it out yet?

  5. #25

    Join Date
    Jul 2015
    Location
    Woburn, MASS
    Posts
    26
    +1
    2
    Quote Originally Posted by zylinderkopf View Post
    figure it out yet?
    I'm still working on this ski this thing is a POS and I DO not recommend anyone buy any of the new sea doos.

    I had to replace the back hatchs ($100 each) They were warped and leaking which is how I was getting into bildge. I tried new gaskets and that didnt work they were actually warped!
    I had to replace the hood (it was warped and didnt shut properly $400 from WCSS.
    I now have IBR resistance error which is bad IBR $1000 or bad Main harness $600

    The machine runs fast now with a new impeller (the old one was in worst shape than i though upon first inspection). It still idles like crap though. Here is a summary of what I have done regarding Idle issue:
    NEW throttle body
    NEW Pressure sensor AND Temp sensor in airbox
    NEW airbox
    NEW Fuel pump
    NEW fuel line to injector rail

    Thing still idles like shit. Next thing I'm thinking is the throttle actuator in the handlebars because i unplugged it and it changed the idle speed.

    Meanwhile i have been using my 2008 and 2007 RXP'p with NO issues!


Page 3 of 3 FirstFirst 1 2 3

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2008 STF-15x is running rough at idle to low speeds
    By geissap in forum Kawasaki PWC Performance (4-stroke)
    Replies: 3
    Last Post: 06-19-2010, 11:10 AM
  2. FXHO running rough at idle
    By bldguy65 in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 06-03-2010, 01:34 AM
  3. 87 650 sx runs ruff at idle
    By sschne62 in forum Kawasaki PWC Performance (2-stroke)
    Replies: 6
    Last Post: 04-27-2010, 09:45 PM
  4. Engine Run Away At Idle
    By christiaan in forum Polaris Open Discussion
    Replies: 4
    Last Post: 05-27-2008, 10:44 AM
  5. 1300 rough at idle??
    By flyboy in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 08-16-2006, 03:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •