Results 1 to 6 of 6
  1. #1

    Join Date
    Apr 2018
    Location
    fort worth, texas
    Posts
    15

    97 polaris sl900 coil packs

    Does anyone know if the coil packs are interchangeable with any other year models. wondering if it would work on a 2002 genesis 1200?


  2. #2
    casey67's Avatar
    Join Date
    Sep 2006
    Location
    Lemont,IL
    Posts
    3,130
    +1
    65
    part #

  3. #3
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,189
    +1
    1,987
    Quote Originally Posted by stacymerz@sbcglobal.net View Post
    Does anyone know if the coil packs are interchangeable with any other year models. wondering if it would work on a 2002 genesis 1200?
    As far as I know all the red engine carburetor ignition coil packs are interchangeable.

    be aware that there are two different versions of the three cylinder coil pack from the 900/1050 engines. The ‘firing order’ is sequenced differently, do no assume the old pack and the new pack have the same internal cylinder order unless they have the same part number.

    Click on my signature link to find more info on the 900/1050 coil packs.

    Also, some 900/1050 engines had a different crankshaft firing order, with CEN and PTO firing order swapped. MAG firing (cylinder one, at front of the engine) is always correct.

  4. #4

    Join Date
    Apr 2018
    Location
    fort worth, texas
    Posts
    15
    part # is different but they look the same , the only difference I can see is the wires are different colors but same amount of wires.

  5. #5

    Join Date
    Apr 2018
    Location
    fort worth, texas
    Posts
    15
    ok thanks

  6. #6

    Join Date
    Aug 2006
    Location
    Homer Glen Il.
    Posts
    8,745
    +1
    119
    yes with the newer coil you need to use it's wires

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 Polaris SL900 ignition problem
    By git_sum in forum Polaris Projects
    Replies: 3
    Last Post: 04-16-2010, 10:20 AM
  2. 97 Polaris SLT 780
    By krirish in forum Polaris Open Discussion
    Replies: 13
    Last Post: 06-02-2007, 08:53 AM
  3. 97 Polaris SLT780 not run for 2 years
    By jsplayin in forum Polaris How To & FAQs
    Replies: 6
    Last Post: 05-31-2007, 08:48 AM
  4. SLTX 97 Polaris,jet pump problem
    By grifter in forum Polaris How To & FAQs
    Replies: 10
    Last Post: 05-24-2007, 03:09 PM
  5. Need help with coil packs....
    By GeoRXT in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-15-2006, 05:41 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •