Results 1 to 4 of 4
  1. #1

    Join Date
    May 2007
    Secord Lake and Sterling Hts., MI

    03 Polaris MSX 140 Limp Mode Problem

    I have two 03 Polaris MSX 140's. One works great the other does not. The problem child has 50 hours on it. Always winterized and serviced at the buying dealer. When I run out on the lake, it starts fine and may even run fine for a period, then randomly it goes into limp mode (bap, ba, bap). You then must take your finger off the throttle, float for a moment and it will run again, then randomly (bap, ba, bap). This happens in smooth or rough water. No warning lights on the dash. The dealer said it had some fuel line clamp leaks, and they replaced them. Then after a half hour of rough riding, limp mode (bap, ba, bap) and it took forever to get home because it wouldn't go for more than 15 seconds at a time. Of course the dealr says, too hard to dupicate as no codes are set in their machine when hooked up. What should I look for or suggest to the dealer? I know I should go to another dealer, but there are none willing to work on Polaris watercraft for hours around. Any help or suggestions would be appreciated.

    P.S. It has fresh gas, new plugs and is full of oil. Nothing is different or serviced different the my other with 60 hours that runs fine.

    P.S.S. When this happens nothing comes on the display, it just shuts down and won't go, all the while going ba, brap, ba, ba. Once it settles down and you take your finger off the throttle like an idle, it will then go again until it decides to not move and make the horrible sounds again. This seems to be completly random, but the last time it happened it was over and over as I tried to get home.

  2. #2
    Welcome to the GH you stand a way better chance of getting some help over here!

  3. #3
    ph2ocraft's Avatar
    Join Date
    Apr 2006
    Campbell, Ca.
    sb, I had a similar problem with my 03, the items Polaris replaced under warrant were.
    Wiring harness
    Send injetors and ECM fo calibration
    New Plugs

    The problem found after the warranty expired was the stator, it was loose where it mounts to the engine. It appears the hardware used is to long and doesn't sufficiently tighten the stator into position.

    I'm not saying this is your answer but it's been the solution to more than a few 03 MSX 140's. I would start with the TPS. You can even borrow it off your good unit and at least give it a test. I'm sure others will have some great ideas as well.

    Oh, and WELCOME to the Green Hulk Forums.

  4. #4
    Bernie's Avatar
    Join Date
    Aug 2006
    Perth Australia
    Sounds like tps syndrome .Check connector to tps and crimp female conn to ensure good connection .Let us know


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2004 MSX 110 limp mode problem
    By Striker in forum Polaris Open Discussion
    Replies: 56
    Last Post: 10-27-2016, 10:38 AM
  2. 03 Polaris MSX 140 HO Drive Shaft removal troubles
    By leedanger in forum MSX/Matrix
    Replies: 2
    Last Post: 08-13-2012, 03:01 PM
  3. Replies: 4
    Last Post: 03-07-2011, 12:00 PM
  4. 2003 polaris MSX 140 problem - need help
    By orrjoe in forum Polaris Open Discussion
    Replies: 0
    Last Post: 08-25-2007, 01:41 PM
  5. Limp Mode H2O Temp Sensor Polaris MSX 140
    By H20Carver in forum Polaris Open Discussion
    Replies: 2
    Last Post: 06-19-2007, 04:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts