Results 1 to 8 of 8
  1. #1
    lanz_scott11's Avatar
    Join Date
    May 2018
    Location
    Portage Lakes, Oh
    Posts
    3

    High Temp Light Flashing and Buzzer HELP!! 2005 RXT

    This is my first time posting and I am new to the forum but I have a 2005 RXT and every time I start my ski the check engine message is flashing, the red high temp light is flashing , and the buzzer goes off. I've tried to check the engine codes and just END comes up. Ive replaced the coolant temp sensor but I'm looking for some advice before I go tearing into it. The ski runs fine and everything sounds good. I am new to PWCs so I apologize for the lack of knowledge in advance.


  2. #2
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,692
    +1
    40
    Check the pissers in your j-pipe, there are three in there that get clogged with sand or general debris over time.

  3. +1 by:


  4. #3
    lanz_scott11's Avatar
    Join Date
    May 2018
    Location
    Portage Lakes, Oh
    Posts
    3
    Would this cause the high temp light and buzzer to sound immediatelywhen starting the ski?

  5. #4
    Banned User
    Join Date
    Dec 2017
    Location
    USA
    Posts
    348
    +1
    23
    Would this cause the high temp light and buzzer to sound immediatelywhen starting the ski?

    Yup. It can also be a bad exhaust temperature sensor.

  6. +1 by:


  7. #5

    Agreed

    Agreed

  8. #6
    lanz_scott11's Avatar
    Join Date
    May 2018
    Location
    Portage Lakes, Oh
    Posts
    3
    Where is the exhaust temp sensor located? Is it the same part as the coolant temperature sensor. Thanks for all the feedback!

  9. #7
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,692
    +1
    40
    Quote Originally Posted by lanz_scott11 View Post
    Where is the exhaust temp sensor located? Is it the same part as the coolant temperature sensor. Thanks for all the feedback!
    This sensor is located in your waterbox On the exit side. These can go bad but given the year of the ski, i’m betting on the pissers, plus it’s free to do, just requires a bit of your time. Some drill them out one size larger and have good success.

  10. #8
    They have any ohming testing?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 97 gp 1200 bogging on top end, w. Temp light flashing
    By drabramczyk@gmail.com in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-13-2016, 04:44 PM
  2. Gp1300r showing temp light warning and has no spark.
    By rsanson21 in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 09-18-2015, 06:21 PM
  3. 2002 Polaris Freedom Engin Light flashing and will not crank
    By snackcakes97 in forum Polaris Open Discussion
    Replies: 2
    Last Post: 08-16-2011, 05:38 PM
  4. 04 rxp riva stage 2 kit high temp light limp mode
    By crzyjetskr in forum 4-Tec Performance
    Replies: 17
    Last Post: 06-26-2011, 02:50 PM
  5. Red Oil light flashes and goes to rev limiter mode
    By bmmoore42 in forum Polaris PWC Performance
    Replies: 3
    Last Post: 06-11-2011, 08:05 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •