Page 2 of 2 FirstFirst 12
Results 11 to 19 of 19
  1. #11
    Titan_Joe's Avatar
    Join Date
    Jan 2015
    Location
    Pottstown PA
    Posts
    852
    +1
    177
    Check your ride plate and intake grate bolts they may be loose

  2. #12
    From the black soot I observe in your first picture, I believe you might be having issues with your carbon ring.

    I've read on some thread that polishing the floating ring's surface (start with 400 grit sandpaper and go up until at least 1000 grit) solved the problem. You might want to give that a try!

    Let me know if that helped!

  3. #13

    Join Date
    Mar 2009
    Location
    washington
    Posts
    10
    +1
    1
    As Titan Joe said I had a 2014 GTI 155 which had water in the hull, took it to the dealer and was told the leak was coming from the forward bolt on the intake grate where it comes through the hull, it was not sealed properly and it was located right under the carbon seal.

  4. #14
    So the way I read the complaint, water leaking from the ride plate would not explain how its getting on the bunks of the trailer. Water does not drip up, the ride plate is lower than and between the bunks I assume. I would guess the sponsons (through bolt holes) are leaking, that would explain the water getting on the bunks and being hard to see the leak.

    There is only so many holes in the boat where water can leak. If the hull is not cracked look at all the places there is holes (bolts/screws). Swim step, sponsons, gas vent, tow hooks, etc

  5. #15
    mibunkerking's Avatar
    Join Date
    Aug 2008
    Location
    Jax,Fl
    Posts
    2,392
    +1
    146
    You guys realize this thread is a year old right?

  6. #16
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,834
    +1
    367
    Quote Originally Posted by mibunkerking View Post
    You guys realize this thread is a year old right?
    Slow leak?


  7. #17
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,134
    +1
    223
    Quote Originally Posted by 2_FST_4_U View Post
    From the black soot I observe in your first picture, I believe you might be having issues with your carbon ring.

    I've read on some thread that polishing the floating ring's surface (start with 400 grit sandpaper and go up until at least 1000 grit) solved the problem. You might want to give that a try!

    Let me know if that helped!
    Yes this works but for the cost of a new CR kit $70-80 minus well get it new and over with .

  8. #18
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,134
    +1
    223
    Quote Originally Posted by mibunkerking View Post
    You guys realize this thread is a year old right?
    Ahhhh sh!t , just noticed this also forget it he probably sunk already ,lol.


  9. #19
    Quote Originally Posted by mibunkerking View Post
    You guys realize this thread is a year old right?
    I didn't notice !!


Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Leaking carbon seal 2016 Seadoo rxp
    By jserr68594 in forum 4-Tec Performance
    Replies: 1
    Last Post: 04-26-2018, 12:36 PM
  2. Water in oil concern Seadoo RXP 300, updated
    By jserr68594 in forum Sea Doo Open Discussion
    Replies: 5
    Last Post: 04-26-2018, 09:16 AM
  3. SOLD 2016 Seadoo RXP 300
    By RXP85 in forum Sea Doo 4Tec Skis
    Replies: 4
    Last Post: 07-12-2017, 10:55 AM
  4. 2016 Seadoo rxp 300 to buy or not buy?
    By jserr68594 in forum 4-Tec Performance
    Replies: 28
    Last Post: 03-16-2016, 09:08 PM
  5. SLT hull water leak
    By Shoog13 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 06-30-2010, 03:27 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •