Results 1 to 3 of 3
  1. #1

    Join Date
    Oct 2012
    Location
    Austin, TX
    Posts
    17

    2004 Yamaha SUV dummy lights question

    Yesterday all four of my warning lights came on my SKI when riding. They won't go off. Nothing is beeping either. Ski has been parked for 24hrs...still on. Removed battery - still on?

    Ski has no issues at all.
    Temp - Fine
    Battery/Voltage - Fine
    Oil level - Straight Mix-Dplate
    Fuel - fine

    I own two SUV's and have hundreds of hours on both....never had this happen.

    Can anyone help point me in the right direction here?

    Couldn't find anything in manual. Maybe I'm the dummy.

    Thanks guys.


  2. #2
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Lake Livingston, TX
    Posts
    652
    +1
    74
    I would check and clean all electrical plugs/connections. You might also want to try another gauge.

    -Greg

  3. #3
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,357
    +1
    131
    Sounds like a bad gauge.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 1
    Last Post: 03-22-2014, 06:22 PM
  2. 2004 Yamaha XLT 1200 - Pisser Question - How Many
    By timscherer in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 07-24-2013, 10:59 AM
  3. 2004 Yamaha FX HO gas questions??
    By BIGtymSki in forum Yamaha PWC Performance (4-stroke)
    Replies: 6
    Last Post: 11-28-2012, 06:28 AM
  4. 2001 and 2004 Yamaha 1200 SUV Primer pump question
    By macGruber in forum Yamaha PWC Performance (2-stroke)
    Replies: 7
    Last Post: 03-24-2012, 02:32 PM
  5. yamaha SUV question
    By Toolman in forum Yamaha Old School Skis
    Replies: 7
    Last Post: 01-18-2008, 07:15 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •