Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 49
  1. #21
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,796
    +1
    213
    Your injector volts are most likely low. Either due to a bad flywheel/stator, or a bad EMM. Measure open circuit AC volts on all 5 stator winding pairs while cranking (pins 1-12, 2-11, etc)


  2. #22
    Yes I poured more fuel down the throttle bodies this time and it started again. High idle at 1st then revved fine for 10 or so seconds and died like it ran out of fuel. Wont start after. Tested the plugs going to the fuel injectors with my multimeter and they all flash 18-20 volts at 1st the settle down to 10- 11 volts constant while cranking. Both leads of meter in both sockets of plug

  3. #23
    I have to head to work so I can check the stator tomorrow. I dont have the manual or a diagram and this is new to me. Is there a plug coming from the stator or do I need to take the cover off and remove the flywheel? Thanks for all your help! Jason
    P.s. when I tested the injector plugs I had it on DC volts.

  4. #24
    Found how to test the stator. Will report back tomorrow. Thanks

  5. #25
    So found out it was the stator. One of the wires was broken. The flywheel looks like the sleeve wlis coming apart and caused it. Not sure why but a new stator and flywheel should get me going. There was some oil on the stator, no puddle but it was all over it. Is that a crank seal? Thanks Jason

  6. #26

  7. #27

  8. #28
    2002 Genesis i 1200 started acting up running rough then wouldn’t get above 30 mph also reverse stopped working. Finally it wouldn’t even start. Local shop had it for many weeks and threw expensive hard to find parts at it: first throttle position sensor, then a start-stop switch. Finally they said the EEM was no longer responding and to send it to Lakeside Tech for a rebuild. Received the rebuilt EEM back and took it on the lake yesterday. It started right up ran like new! Thanks Lakeside Tech! (hopefully it will keep running another 14 years)

  9. #29
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,399
    +1
    1,880
    Good to hear you are back on the water, and that Lakeside Tech made your EMM good again.

    Those 'expensive parts' that got swapped out, you should get the old parts back as they may still be good. Keep the TPS as a spare, I suggest.

    The other 'good removed parts' parts you might be able to sell.

    Quote Originally Posted by Nwdaddy208 View Post
    2002 Genesis i 1200 started acting up running rough then wouldn’t get above 30 mph also reverse stopped working. Finally it wouldn’t even start. Local shop had it for many weeks and threw expensive hard to find parts at it: first throttle position sensor, then a start-stop switch. Finally they said the EEM was no longer responding and to send it to Lakeside Tech for a rebuild. Received the rebuilt EEM back and took it on the lake yesterday. It started right up ran like new! Thanks Lakeside Tech! (hopefully it will keep running another 14 years)

  10. #30
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,796
    +1
    213
    Quote Originally Posted by Nwdaddy208 View Post
    2002 Genesis i 1200 started acting up running rough then wouldn’t get above 30 mph also reverse stopped working. Finally it wouldn’t even start. Local shop had it for many weeks and threw expensive hard to find parts at it: first throttle position sensor, then a start-stop switch. Finally they said the EEM was no longer responding and to send it to Lakeside Tech for a rebuild. Received the rebuilt EEM back and took it on the lake yesterday. It started right up ran like new! Thanks Lakeside Tech! (hopefully it will keep running another 14 years)
    Thanks for the positive feedback, and thanks again for your business

Page 3 of 5 FirstFirst 12345 LastLast

Thread Information

Users Browsing this Thread

There are currently 2 users browsing this thread. (0 members and 2 guests)

Similar Threads

  1. Replies: 52
    Last Post: 03-02-2018, 09:35 AM
  2. Ficht EMM repairs - alternative to DFI, Marine Computer, the eBay guy
    By jimfleming88 in forum Polaris Open Discussion
    Replies: 16
    Last Post: 01-14-2018, 07:18 PM
  3. WTB - Parts Looking for a FICHT EMM working or not - Do not need injectors
    By UnityRacing in forum Kawasaki Classifieds
    Replies: 4
    Last Post: 04-23-2015, 09:48 AM
  4. Options for new strainer?
    By RXPteamtimebomb in forum 4-Tec Performance
    Replies: 1
    Last Post: 05-16-2010, 06:05 PM
  5. Any other options for new MPEM ??
    By canuck in forum 2-Stroke Performance
    Replies: 5
    Last Post: 03-25-2010, 03:30 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •