Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 56
  1. #21
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    Well I did do one thing productive today since the dealer decided to not open at all today. I know I did them before but I wasn’t happy so I went a little fancier. Click image for larger version. 

Name:	07D2404B-FD17-45B3-9A41-64ACDFE9712D.jpg 
Views:	130 
Size:	79.0 KB 
ID:	426567


  2. #22
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    So I got the harness today so I don’t have to splice any wires. The problem is the factory low voltage cutoff/warning. This is god awful loud and stays on until you start the ski or disconnect the key and cycle the system on. Smart indicators but the issues is the voltage threshold is so high it triggers the alarm after only about a minute. Since the factory harness is hot ground and bus. I think I’m going to do an override button with a relay to pull power from the full time hot and power the radio on wire. That way I can leave the system asleep and manually turn on the radio but will still automatically come on and warn me off low voltage till I override it. Also going to utilize the factory grommet to pass the wires thru the hood. The cutting out in the video is my phone getting texts

    Click image for larger version. 

Name:	929B0356-9B2F-4E69-B6F7-C4CF0D3AFB08.jpg 
Views:	635 
Size:	59.1 KB 
ID:	426587

    Last edited by Madkidd; 01-18-2018 at 04:14 PM.

  3. #23
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    Ok so this past week I finally wrapped things up. Did the muffler/baffle removal, stereo done including the override so I don’t have to have the BUS powered up, and wired remote. While I had the inter cooker out I couldn’t help but think why didn’t BRP put the plug in a better location? Also finished up the registration numbers on the ski/trailer along with the reflective strips down the length of the trailer since ski trailers aren’t as well lit as some. Also as I was adding photos I remembered I did the Graco filter for the inter cooler. The drone on this hull is actually different than my previous experience with the GTI hull. It’s hard to explain but a deeper tone and not so intrusive, as if it starts at a faster speed. Just had a short outing since we had a 60 degree afternoon.
    Click image for larger version. 

Name:	C44E6596-A030-4BC7-95CE-A7191166A354.jpg 
Views:	95 
Size:	79.0 KB 
ID:	427000
    Click image for larger version. 

Name:	2D93FB11-C1DF-4334-8C56-2F0316FCD184.jpg 
Views:	88 
Size:	110.2 KB 
ID:	427001
    Click image for larger version. 

Name:	54DD9E9B-2953-4F24-ADE6-BFDD9C3B6A09.jpg 
Views:	105 
Size:	56.7 KB 
ID:	427003
    Click image for larger version. 

Name:	28B0A1BB-C4E8-4C11-A292-20B9EF8B0747.jpg 
Views:	96 
Size:	56.4 KB 
ID:	427004
    Click image for larger version. 

Name:	711D2EF7-A0C4-430C-B8A7-4542D11538F9.jpg 
Views:	93 
Size:	39.9 KB 
ID:	427005
    Click image for larger version. 

Name:	E071430E-E9F3-4F07-A6B8-F70068989AD0.jpeg 
Views:	135 
Size:	157.9 KB 
ID:	427006
    Click image for larger version. 

Name:	0D9C26B1-362E-4EFE-8A14-E145B403AC0A.jpg 
Views:	116 
Size:	88.0 KB 
ID:	427007

  4. #24
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    So I got back out today and now have a total of 4 hours and at 3 hours it was hitting the speed limiter and will hit 69 at 8080 and it backs it down to 68 mph @ 8020/8040 RPM. I could be crazy but it will only hit 69 for a moment on acceleration, but not when staying WOT even at 2 bars of fuel compared to 68 at 5 bars. And Ofcourse this is all dash speeds, I don’t care for exact numbers just reference numbers. I just have to decide what to do next, I think a prop change would do wonders but I truely think it’s GPS limiter and Ofcourse rpm which was never a question.



  5. #25
    REID2168's Avatar
    Join Date
    Jun 2007
    Location
    My House
    Posts
    8,734
    +1
    299
    Quote Originally Posted by Madkidd View Post
    So I got the harness today so I don’t have to splice any wires. The problem is the factory low voltage cutoff/warning. This is god awful loud and stays on until you start the ski or disconnect the key and cycle the system on. Smart indicators but the issues is the voltage threshold is so high it triggers the alarm after only about a minute. Since the factory harness is hot ground and bus. I think I’m going to do an override button with a relay to pull power from the full time hot and power the radio on wire. That way I can leave the system asleep and manually turn on the radio but will still automatically come on and warn me off low voltage till I override it. Also going to utilize the factory grommet to pass the wires thru the hood. The cutting out in the video is my phone getting texts




    sounds GREAT man.
    .........my next NEW ski will have tunes FO SHO.............GOOD WORK!!!!!!!!!

  6. #26
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    Preciate it. After about 60 I could only hear it with my shield cracked open. But I was wearing a full face helmet because I didn’t want freezing water spraying me in the face. Summer will be a different story.
    Last edited by Madkidd; 03-09-2018 at 10:25 PM.

  7. #27
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    So as I’m waiting to hear back from Riva I decided to finish up the cosmetic touches. Changed the mirrors up a little since the solid orange wasn’t working for me, swapped the orange grips for black, and the panel over the gauges just ordered a new one with no decal since it was fairly cheap. Took of more of the wake decals to clean it up a bit and decided for a simple checkered flag pattern for a little contrast on the rear, also some of you may know what the decal is on the front. I do believe I’m completely done with the visual aspects now. Additionally I realized I never posted the wired remote for the stereo.

    Click image for larger version. 

Name:	E8556157-18A6-418B-AAF1-DE0E94D788FB.jpg 
Views:	80 
Size:	26.3 KB 
ID:	430377
    Click image for larger version. 

Name:	72BAF291-73C8-4808-878C-56771D4EC41D.jpg 
Views:	87 
Size:	63.1 KB 
ID:	430375
    Click image for larger version. 

Name:	090BD667-6A7D-42C7-A580-45B8A8CB96B4.jpg 
Views:	101 
Size:	49.1 KB 
ID:	430376

  8. #28
    moparguy's Avatar
    Join Date
    Sep 2016
    Location
    Niagara Falls, Ontario
    Posts
    1,558
    +1
    308
    The Saabdoo, the logo on the front is the Saab logo isn't it? Ski looks great by the way!

  9. #29
    Madkidd's Avatar
    Join Date
    Jan 2018
    Location
    Athens, Ga
    Posts
    192
    +1
    9
    Quote Originally Posted by moparguy View Post
    The Saabdoo, the logo on the front is the Saab logo isn't it? Ski looks great by the way!
    Sure is, I removed all my badges and had new emblems made without the name, bet you’ve never seen one of these before.
    Click image for larger version. 

Name:	3A80C842-1437-41E9-AB20-AAFD533085AB.jpg 
Views:	101 
Size:	75.5 KB 
ID:	430382

  10. #30
    GOT BOOST? Dockside's Avatar
    Join Date
    Dec 2008
    Location
    Ontario, Canada
    Posts
    4,172
    +1
    180
    Quote Originally Posted by Madkidd View Post
    Sure is, I removed all my badges and had new emblems made without the name, bet you’ve never seen one of these before.
    Click image for larger version. 

Name:	3A80C842-1437-41E9-AB20-AAFD533085AB.jpg 
Views:	101 
Size:	75.5 KB 
ID:	430382
    Saab 9-7x? Basically a re-badged Chevy trailblazer and gmc envoy

Page 3 of 6 FirstFirst 12345 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2017 wake pro 230
    By svrider in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 07-06-2017, 09:42 PM
  2. 2011 wake pro 215 limp mode
    By Madmike1 in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-03-2011, 09:20 PM
  3. which block offs for '09 wake pro?
    By got wake? in forum 4-Tec Performance
    Replies: 3
    Last Post: 11-22-2010, 09:24 PM
  4. First Impressions/First ride 2010 Wake Pro 215.
    By vonnie in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 04-25-2010, 12:19 PM
  5. Seadoo wake pro 215 good boat ?
    By sloan_william@msn.com in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 09-25-2008, 08:43 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •