Page 1 of 2 12 LastLast
Results 1 to 10 of 17
  1. #1
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    124
    +1
    2

    2018 RXP-X ~Reduced Full Power~ Slight Drone above 5k rpm

    Had my 2018 PX out yesterday for a cruise. Engine sound above 5,000 rpm sounded/felt different. 6-7k a slight drone and light vibration is felt. Not getting full power out of it. Struggling to get 70-72mph out of it, have seen 75-77 on the dash. Its not mis-firing or running rough, just not optimal. I just installed a catch can, I doubt that has anything to do with this. 14 hrs on it. Called my local dealer, "they will gladly look at it after they give it a 10hr Service"....


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,972
    +1
    1,947
    Check jet pump for possible debris caught on impeller blade or stator vane. Also look for damage to impeller blades (bent, rock ding, etc).

    Look into the water inlet under the hull with a good flashlight, and into the jet pump exit nozzle (engine off, of course).

  3. #3
    Mpeavler's Avatar
    Join Date
    Dec 2005
    Location
    Elwood , Indiana
    Posts
    5,259
    +1
    186
    Agree *^^^^^^^

  4. #4
    id be at the dealer letting them figure out the issue. being a 18 model it does have full warranty right?

  5. #5
    SplishSplash's Avatar
    Join Date
    May 2006
    Location
    Belle River Ont Canada
    Posts
    1,629
    +1
    181
    Rule #1, made a change, lost power, back out change. I doubt it's the catch can, but remove it, see if problem goes away.
    Also , check your pump for debris as mentioned.

    Or just let the dealer deal with it

  6. #6
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    124
    +1
    2

    Quote Originally Posted by $allenk1982 View Post
    id be at the dealer letting them figure out the issue. being a 18 model it does have full warranty right?
    Yes 3yr Warranty.

    Dealer is trying to sell me a 10hr service BEFORE, addressing my performance complaint. Which I won't do. 10hrs is 3 rides for me...lol

  7. #7
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    40,972
    +1
    1,947
    Quote Originally Posted by BallaRXP View Post
    ...

    Dealer is trying to sell me a 10hr service BEFORE, addressing my performance complaint. Which I won't do.

    10hrs is 3 rides for me...lol
    Why would you not want the ten hour initial service to be performed?

    During that initial service the dealer may find something, such as spark plug contamination or a loose electrical item.

  8. #8

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,602
    +1
    939
    Quote Originally Posted by K447 View Post
    Why would you not want the ten hour initial service to be performed?

    During that initial service the dealer may find something, such as spark plug contamination or a loose electrical item.
    Probably cause they will charge him about $500 I'm guessing.

    The 2018 manual says engine oil doesn't need to be replaced till 50hours, spark plugs at 200hours. If there are any loose hoses etc that should've been covered under prep/setup..but I know they don't always check them as I had a totally in clamped hose in a my 2016 tx300 that I found when I did my inspection. On my 2018 TX300 I took the seat/back cover off and did my own inspection/snug all clamps as well as rinsed out all the dust and lubed all the shiny stuff. It did look like the clamps where all tightened in a consistent tension though(for the first time).

    That being said I always change my oil in my new skis around 10 hours. I had to replace my plugs in my 2016px300 to get rid of some rough idle issues around 50 hours.

    I'm guessing you got something in your pump, take a flash light and look up into the intake grate and makes sure the impeller looks undamaged. After that, feels like a warranty issue to me.

  9. #9
    BallaRXP's Avatar
    Join Date
    Oct 2010
    Location
    Clearwater, FL
    Posts
    124
    +1
    2
    You guys are good!

    1' of crab trap line on my drive shaft. I swear this new PX300 has a bad problem with sucking crap into the pump. It was Seaweed last week, this week it's a crap trap line. Lol

  10. #10

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,602
    +1
    939
    Quote Originally Posted by BallaRXP View Post
    You guys are good!

    1' of crab trap line on my drive shaft. I swear this new PX300 has a bad problem with sucking crap into the pump. It was Seaweed last week, this week it's a crap trap line. Lol
    That'll do it! So much for Clear Water.....

    You might want to carry a few razor blades with you, just in case. You can always go to beach and few guys flip it on it's side and cut away at stuff like that...but a normal pocket knife is usually not sharp enough or will take you a while.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2010 RXP 255RS RPM Problems only around 7500rpm, not full power
    By tiptronic1812 in forum 4-Tec Performance
    Replies: 3
    Last Post: 05-09-2016, 01:52 PM
  2. 04 RXP F/S Full Riva stage 2
    By 111toybox in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 06-02-2008, 11:33 PM
  3. Seadoo RXP-X too much Power?
    By mirzar1 in forum 4-Tec Performance
    Replies: 40
    Last Post: 10-31-2007, 11:11 PM
  4. RXP lack of full power until warmed up
    By ORL in forum 4-Tec Performance
    Replies: 7
    Last Post: 10-09-2007, 08:01 PM
  5. RXP Riva Pro 4" Power Filter Side Vents
    By Sandy in forum 4-Tec Performance
    Replies: 8
    Last Post: 03-27-2007, 08:39 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •