Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1

    HELP...Kawi 1100 B1 Bogs on Hard Right Turns

    Hey All,

    I built an 1100 B1 and I'm having an issue that I cant seem to figure out. When I make a hard Right Turn the ski will bog and it will take a while riding at 1/4 throttle to get back up to full rpm. I was told that I was having a lean issue, and to flip my carb rack so that the pumps are on the starboard side facing away from the motor. I did that, and now the problem happens when I turn hard Left.

    Any Ideas???

    Thanks


  2. #2
    swlamarshrunner's Avatar
    Join Date
    Dec 2014
    Location
    Lake Charles, Louisiana
    Posts
    591
    +1
    117
    How much fuel is in your tank when this is happening, what is your fuel pickup setup like and which carbs are you running?

  3. #3
    Open the carbs up and check the floats.

  4. #4
    Hurricane1000's Avatar
    Join Date
    Oct 2005
    Location
    Gulf of Mexico
    Posts
    1,005
    +1
    106
    Sounds like you need a new fuel pump or clean your fuel pump as you are not getting enough fuel pressure

  5. #5
    Typical "left turn syndrome" that alot of carb fed marine engines have. There is a section in the Mikuni Super BK manual that describes exactly this in some detail

  6. #6
    Update,

    I have flipped my carb rack and the problem moved to the other side (left turn bog).

    I lowered popoff from 21 to 18, and still the same problem. Carbs are clean and all parts are new.

    I tested a set of fresh rebuilt (by Tim) Novis and no change.

    New blowsion fuel pickup, always full tank of fresh gas.

    Tested with and without fuel restrictors as well.

  7. #7
    Tool Bag water worx's Avatar
    Join Date
    Aug 2006
    Location
    Sunny Fla
    Posts
    2,359
    +1
    132
    Quote Originally Posted by Heloboby7 View Post
    Open the carbs up and check the floats.
    Really ???

  8. #8
    Quote Originally Posted by water worx View Post
    Really ???
    Lol double pumper

  9. #9
    Update. I installed and valve body from a set of NOVI carbs that has a bearing pressed into the hole for the check valve, and a groove milled into the surface.

    It almost solved the problem completely, but after about 5 laps it will start to bog again, but recovers much faster.

    The only real solution to this is to rotate the carbs somehow. I purchased a Rhaas plate for the GP1200 carbs, and I'm going to try and modify it to run my carbs on it. Click image for larger version. 

Name:	20181119_182626.jpeg 
Views:	39 
Size:	57.5 KB 
ID:	442654

  10. #10
    Interesting mod there, i just ordered a Pro-Tec intake manifold to replace the RIvA one on the engine going into my B1 to allow the OE gp1200 mounting in hopes of avoiding this.

Page 1 of 2 12 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Waveraidder 1100 help needed. lean bog on take off?
    By MikeSW in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-24-2017, 02:58 PM
  2. '99 kawa 1100 stx bogs on WOT
    By waxsworth in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-08-2014, 01:17 PM
  3. 1100 Raider bogging on takeoff(Fixed) Engine Rebuilt and Running!
    By raiderteen in forum Yamaha Old School Skis
    Replies: 31
    Last Post: 07-29-2013, 11:11 AM
  4. HELP: zxi 1100 and 900 stx low speed bogging issue
    By grahams in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 03-23-2013, 10:36 PM
  5. GPR bogs down when turning hard right...
    By cmgww in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-13-2010, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •