Page 2 of 2 FirstFirst 12
Results 11 to 12 of 12
  1. #11
    Quote Originally Posted by Z28ricer View Post
    Interesting mod there, i just ordered a Pro-Tec intake manifold to replace the RIvA one on the engine going into my B1 to allow the OE gp1200 mounting in hopes of avoiding this.
    I didnt know Pro-Tec still makes that. I'll check it out.


  2. #12
    They have it on their website and sure took my order for it, sure hope it shows up, otherwise i guess I’ll be installing a stock 65U piece.

Page 2 of 2 FirstFirst 12

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 96 Waveraidder 1100 help needed. lean bog on take off?
    By MikeSW in forum Yamaha PWC Performance (2-stroke)
    Replies: 10
    Last Post: 08-24-2017, 02:58 PM
  2. '99 kawa 1100 stx bogs on WOT
    By waxsworth in forum Kawasaki PWC Performance (2-stroke)
    Replies: 0
    Last Post: 07-08-2014, 01:17 PM
  3. 1100 Raider bogging on takeoff(Fixed) Engine Rebuilt and Running!
    By raiderteen in forum Yamaha Old School Skis
    Replies: 31
    Last Post: 07-29-2013, 11:11 AM
  4. HELP: zxi 1100 and 900 stx low speed bogging issue
    By grahams in forum Kawasaki PWC Performance (2-stroke)
    Replies: 12
    Last Post: 03-23-2013, 10:36 PM
  5. GPR bogs down when turning hard right...
    By cmgww in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 07-13-2010, 05:33 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •