Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 31
  1. #21
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    My mfd is also freaking out rn, it only shows me the time, I can't cycle

  2. #22
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    Quote Originally Posted by K447 View Post
    Spark is still weak?

    Move the negative battery cable end from the bed plate to a stud on the PTO intake manifold. Sometimes the bed plate is not properly electrically grounded to the actual engine block.
    Moved it, still basically no spark

  3. #23
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    Update:
    New plugs
    New battery
    Not flooded
    Weak/little to no spark
    Mfd is stuck on time, and fuel/oil level.
    Moved ground to pto head.

    Bad kill switch?

    Tested compression this morning, 115/110/115


    Also might have toasted the stator ground wire... I normally have boots that cover the battery terminals to insulate it from the cdi box, but last night I got lazy because it was dark and sat the box to the side to get the seat on, this morning I went down to pull the seat to move the ground and I'm guessing I knocked the box onto the terminals with the air intake. when I got the seat off I had a little bit of smoke coming off the contact...
    Last edited by Driver4r; 05-26-2018 at 01:39 PM.

  4. #24
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,059
    +1
    1,969
    There should be a factory rectangular black plastic cover for the entire battery top.

    It’s primary purpose is to prevent shorts to the battery posts.

  5. #25
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    Quote Originally Posted by K447 View Post
    There should be a factory rectangular black plastic cover for the entire battery top.

    It’s primary purpose is to prevent shorts to the battery posts.
    Any other ideas? It wouldn't be so bad if it wasn't still in the water and I have little to no tools/equipment here

  6. #26
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    Odd thing. finally got it started last night. Once it cleaned up it was running awsome.

    Also broke the water feed nozzle off so it got hot. Ran home and grabbed my spare. Changed nozzles in the water lol.
    Last edited by Driver4r; 05-27-2018 at 08:21 AM.

  7. #27
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    41,059
    +1
    1,969
    Quote Originally Posted by Driver4r View Post
    ...
    Also broke the water feed nozzle off so it for hot. Ran home and grabbed my spare. Changed nozzles in the water lol.
    Going from fuzzy memory, one of the 780 models had an oddball ‘twisted’ jet pump wedge and tail cone. The water feed tube was also slightly longer (about 3/8” ?)

    If you install a ‘normal’ jet pump wedge instead of the factory twisted wedge then the water tube must also be changed. Using the longer water tube with a non-twisted pump wedge will result in the pump nozzle cracking when you tighten the pump bolts.

    More details on the ‘twisted’ jet pump variation can be found via my signature link, jet pump section.

  8. #28
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    I have the twisted wedge. The nozzle I broke off this weekend, I repaired last year because of that issue, I tightened down my 1050 spacer and SNAP.
    lesson learned, but yes, I have the twisted wedge


  9. #29
    Driver4r's Avatar
    Join Date
    Jun 2011
    Location
    Nebraska
    Posts
    103
    Update, she only hit 6k on glass this morning, she's averaging 45@5800
    Last edited by Driver4r; 05-27-2018 at 07:29 PM.

  10. #30
    BlueFishCrisis's Avatar
    Join Date
    Aug 2011
    Location
    Medina, Ohio, United States
    Posts
    5,061
    +1
    146
    Quote Originally Posted by Driver4r View Post
    Update, she only hit 6k on glass this morning, she's averaging 45@5500
    With which prop?

Page 3 of 4 FirstFirst 1234 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 0
    Last Post: 04-25-2017, 10:00 AM
  2. Update from our Conversions (Project Second Life)
    By mikeGermany in forum Conversion PWC Performance Skis
    Replies: 2
    Last Post: 07-13-2012, 04:57 PM
  3. First Test from our Conversion "Second Life" RX 4 Tec
    By mikeGermany in forum 4-Tec Performance
    Replies: 5
    Last Post: 02-22-2011, 09:25 PM
  4. Second Life RXRXP
    By mikeGermany in forum Conversion PWC Performance Skis
    Replies: 0
    Last Post: 01-04-2011, 05:06 AM
  5. Seadoo Life Vest
    By 1FastTrespiper in forum Sea Doo Open Discussion
    Replies: 2
    Last Post: 05-11-2005, 01:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •