Page 3 of 3 FirstFirst 123
Results 21 to 22 of 22
  1. #21
    Quote Originally Posted by needmospeedrxpx View Post
    plugs are brand new. less than a month old. i just took apart the jet pump to find a handfull of fishing line around the impeller. could this be my problem?
    Yes now get the impeller fixed and replace the wear ring.
    Last edited by rhjj; 08-01-2017 at 06:22 PM.

  2. #22

    Join Date
    Aug 2016
    Location
    long island ny
    Posts
    33
    So i never concluded this thread but the issue was resolved 3 years ago lol. it was a bad coil pack. while it looked fine there was no voltage on it and i was running on 2 cylinders. thank you everyone for the advice.


Page 3 of 3 FirstFirst 123

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Buying new supercharger advice
    By dguth66 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 09-27-2017, 08:24 AM
  2. Supercharger advice
    By KLBJR in forum 4-Tec Performance
    Replies: 2
    Last Post: 04-29-2015, 07:43 PM
  3. 06 rxp supercharger advice
    By Cheek in forum 4-Tec Performance
    Replies: 16
    Last Post: 04-14-2014, 09:35 AM
  4. Supercharger advice
    By Mi410 in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-11-2012, 05:00 PM
  5. 04 supercharger advice
    By Tripower in forum 4-Tec Performance
    Replies: 6
    Last Post: 10-30-2011, 11:17 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •