Results 1 to 6 of 6
  1. #1
    superair's Avatar
    Join Date
    Aug 2008
    Location
    Smith Lake, Alabama
    Posts
    585
    +1
    46

    Unhappy GP 1800 drive shaft issue / prop

    Well just spent 4 hours trying to remove the prop on my new GP. I thought it would be easier to remove it as the only time the thing has even been ran is during the dealer prep. I was wrong and ended up having to cut the prop to get it off then found out the reason is that the threads are trashed on the end of the shaft. Looks like I'm buying a new shaft this weekend instead of going to the water for the first time.

  2. #2
    Danetwork's Avatar
    Join Date
    Aug 2014
    Location
    DUNEDIN, Florida
    Posts
    604
    +1
    52
    Happen to my buddies FZR. ..

  3. #3
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,396
    +1
    2,914
    Guys do yourself a favor and save a lot of future grief and install this washer system between your impeller and pump. It makes breaking loose impellers much easier

    https://www.4-tecperformance.com/ind...oducts_id=3801

  4. +1 by:


  5. #4
    superair's Avatar
    Join Date
    Aug 2008
    Location
    Smith Lake, Alabama
    Posts
    585
    +1
    46
    Does this replace the factory spacer

  6. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    37,396
    +1
    2,914
    Quote Originally Posted by superair View Post
    Does this replace the factory spacer

    Sure does!

  7. #6
    Iknow is old but i'm having same problem with a 19 gp - impeller stuck on shaft, also had it with a 17 fx svho - the R&D spacer is no longer produced - but this problem never happened on SHO's


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Possible Drive shaft issue or miss alignment or ?????
    By Seanh1150 in forum 4-Tec Performance
    Replies: 10
    Last Post: 04-13-2014, 11:55 AM
  2. WTB - Parts 2003 GTX Drive Shaft and Prop 4tec noncharger
    By Torpedo in forum Sea Doo Classifieds
    Replies: 5
    Last Post: 03-27-2012, 11:48 PM
  3. 2000 Pro 1200 Drive Shaft Issue
    By S12L00X in forum Polaris PWC Performance
    Replies: 48
    Last Post: 10-09-2009, 09:34 AM
  4. FS GP1200,GP 800, XL1200 Drive shaft
    By Tricky1 in forum Yamaha Classifieds
    Replies: 0
    Last Post: 09-19-2009, 11:39 AM
  5. Drive shaft to prop problem? RPM down. *PICS*
    By KeithKman in forum 4-Tec Performance
    Replies: 22
    Last Post: 06-10-2008, 03:07 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •