Results 1 to 4 of 4

Thread: Fault code 158

  1. #1

    Fault code 158

    Anyone know what fault code 158 is? It's a 2017 fx svho with 16 hours, doesn't go into limp mode just beeps up and says check engine.

  2. #2
    Happened to my 2017 gp18Starts then engine shut offs after 3 seconds


  3. #3
    Work Harder, Millions on Wellfare Depend On Us! ultramaxracing05's Avatar
    Join Date
    Aug 2009
    Location
    Beaumont, Texas
    Posts
    3,082
    +1
    141
    this code relates to the Ride system, make sure no ratchet strap is putting the reverse bucket in a bind. Also if the shaft that put the bucket into reverse and forward is in a bind as in when in the up position or reverse position if there is no slack it will throw a code, there need to be a little of wiggle when the bucket is in either position.

    Check that the bucket moves up and down freely by removing the knuckle off the bucket and make sure its free in motion, also make sure that little shaft is not bent.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    43,344
    +1
    2,276
    Quote Originally Posted by Timmymajic View Post
    Anyone know what fault code 158 is?

    It's a 2017 fx svho with 16 hours

    doesn't go into limp mode just beeps up and says check engine.
    Note that a problem cause that has since gone away can still make the dash show/sound the old error.

    After several engine start and shutdown cycles the old error will cease to appear on the dash.

    Check the RiDE bucket and reverse control rod for mechanical problems, and check the white RiDE connector near the electrical panel.

    If nothing seems wrong start the engine, let it idle for maybe five seconds (no cooling water needed). Have someone watch to confirm the reverse bucket moves as it should. Shut it off, wait a minute.

    Start the engine again, pause, and stop it. Wait a minute. Do this 3 or 4 times.

    See if the dash warning has now gone away.

  5. +1 by:


Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Damn Fault Code P1160
    By RXPT400 in forum 4-Tec Performance
    Replies: 46
    Last Post: 03-10-2008, 07:40 PM
  2. Fault code P--1514??? Help...
    By grantuk in forum 4-Tec Performance
    Replies: 11
    Last Post: 01-18-2008, 06:42 AM
  3. LRV-DI Fault code??
    By grantuk in forum 2-Stroke Performance
    Replies: 0
    Last Post: 07-30-2007, 04:54 AM
  4. Fault Code 19 Any ideas
    By Rusty in forum Yamaha Open Discussion
    Replies: 6
    Last Post: 01-08-2007, 06:02 PM
  5. Fault code P0336
    By terryt in forum 4-Tec Performance
    Replies: 3
    Last Post: 08-13-2006, 08:44 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •