Page 2 of 6 FirstFirst 1234 ... LastLast
Results 11 to 20 of 52
  1. #11
    Quote Originally Posted by 11FALLINE View Post
    A small amount of water in the cooler is normal as it condenses moisture out of the charged air. DON'T make a habit of revving it that high out of the water. It is a pointless test and can only do harm to your motor with no load. The relief valve does blow air at idle when the motor is sucking vacuum thru the small hose. Under throttle there is pressure in the small hose which block the relief valve to provide boost. If you push on the inside of the valve and it feels pretty stiff its probably okay.

    You need to check off the other items people have mentioned. Fuel pressure test on the water is ideal but the 3 second fuel prime would give you an idea on whether you're getting enough fuel.

    Using the search button will get you answers a lot faster than waiting for response. There are probably hundreds of threads with people trying to get these machines back to full potential.
    Ok I will check for fuel pressure. The relief valve on my ski blows air for full throttle too. The only time it doesn't release boost out of it is on quick throttle blips. Is this right?


  2. #12
    11FALLINE's Avatar
    Join Date
    Jun 2015
    Location
    Colorado
    Posts
    118
    +1
    12
    It should be completely closed under full throttle. Check or replace the little vacuum hose to the intake manifold and see if the valve spring is still stiff by pressing on the disc shaped valve at the outlet. Is it corroded from saltwater? Whats your location/elevation?

  3. #13
    Quote Originally Posted by 11FALLINE View Post
    It should be completely closed under full throttle. Check or replace the little vacuum hose to the intake manifold and see if the valve spring is still stiff by pressing on the disc shaped valve at the outlet. Is it corroded from saltwater? Whats your location/elevation?
    Never been in saltwater. I will check the spring and vavumn hose. Elevation is about 500ft

  4. #14
    So since this is leaking boost at full throttle do I need to replace it? Even tho it's registering 10 pounds of boost? Where in line is the boost sensor?

  5. #15
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,518
    +1
    692
    Quote Originally Posted by cklemm View Post
    Ok I will check for fuel pressure. The relief valve on my ski blows air for full throttle too. The only time it doesn't release boost out of it is on quick throttle blips. Is this right?
    When and how did you check full throttle leaking of the valve

  6. #16
    Quote Originally Posted by sirbreaksalot View Post
    When and how did you check full throttle leaking of the valve
    I tested it on the hose. Both quick throttle and slow up to full throttle and took the hose off the valve and held my hand there

  7. #17
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,659
    +1
    187
    Quote Originally Posted by cklemm View Post
    I tested it on the hose. Both quick throttle and slow up to full throttle and took the hose off the valve and held my hand there

    theres no load on the motor doing that

  8. #18
    Quote Originally Posted by Region8Ultra250X View Post
    theres no load on the motor doing that
    So I need to test it on the water?

  9. #19
    11FALLINE's Avatar
    Join Date
    Jun 2015
    Location
    Colorado
    Posts
    118
    +1
    12
    From what you've said you have 10 psi at/near your current max rpms of 6500...doesn't sound like you have any boost issue. I would be looking elsewhere for a problem like fuel delivery issues or exhaust leak in hull.

  10. #20
    Quote Originally Posted by 11FALLINE View Post
    From what you've said you have 10 psi at/near your current max rpms of 6500...doesn't sound like you have any boost issue. I would be looking elsewhere for a problem like fuel delivery issues or exhaust leak in hull.
    That's true. I will try a fuel pressure test. Should I check the fuel filter?

Page 2 of 6 FirstFirst 1234 ... LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. ultra 250x not reaching full rpms 6400 max
    By rich7079 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 07-25-2014, 09:25 PM
  2. Not hitting full RPMS 05 rxp
    By 05rxp05 in forum 4-Tec Performance
    Replies: 2
    Last Post: 06-23-2014, 07:01 PM
  3. ultra 250X engine surge and RPM tops at 5300
    By superair in forum Kawasaki PWC Performance (4-stroke)
    Replies: 5
    Last Post: 08-24-2009, 09:42 AM
  4. not getting full RPMs
    By sealz in forum 4-Tec Performance
    Replies: 5
    Last Post: 09-26-2008, 03:11 PM
  5. 96 XP not reaching full RPMS consitently
    By DarthAWM in forum 2-Stroke Performance
    Replies: 14
    Last Post: 04-17-2008, 10:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •