Results 1 to 3 of 3
  1. #1

    2004 Polaris Freedom 700 No Spark!

    Hi

    I have a fully rebuilt Polaris Freedom 700 2004 which is producing no spark.

    I have removed the fly wheel and it is magnetic but how strong should it be?

    Do you guys have any ideas it might be and how I would go about testing for these?

    Thanks in advance


  2. #2
    Moderator HiPeRcO's Avatar
    Join Date
    Jul 2007
    Location
    Upstate NY
    Posts
    2,680
    +1
    195
    Welcome to GH!

    My signature has a link to a wealth of Polaris watercraft related information, I recommend you start there.

  3. #3
    shawndak07's Avatar
    Join Date
    Feb 2012
    Location
    Charleston, South Carolina, United States
    Posts
    79
    +1
    1
    Do you have the lanyard plugged in? Make sure you have a fully charged, new battery. Check fuses and clean off all grounds. Best of luck.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2002 polaris freedom 700 no spark
    By nathanwells301 in forum Polaris Open Discussion
    Replies: 28
    Last Post: 03-22-2016, 07:11 PM
  2. 2003 Polaris Freedom 700 NO SPARK!! PLZ Help
    By Carlangas1921 in forum Polaris PWC Performance
    Replies: 16
    Last Post: 07-23-2013, 08:42 PM
  3. 2002 Polaris Freedom 700, no spark
    By quadracer22 in forum Polaris Open Discussion
    Replies: 8
    Last Post: 07-09-2013, 11:11 PM
  4. polaris virage 700 no spark
    By itismejoshy in forum Polaris Open Discussion
    Replies: 4
    Last Post: 09-18-2009, 03:13 PM
  5. 1998 Polaris SLTH 700 no spark
    By billharris29@gmail.com in forum Polaris Open Discussion
    Replies: 15
    Last Post: 06-27-2008, 10:11 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •