Results 1 to 5 of 5
  1. #1

    Running off hose/flush

    Hi. I have a 95 polaris sl 750 with an ocean pro head on it. Whicj eliminates the normal water bar that would have had the port on the side to hook a hose to. Only has the one hose that runs to the head from the back of the ski. Is this the best hose to T in a hose connector for running the ski in a driveway/flushing it? Or is there another place i should put that in? New to pwcs and just want to make sure i dont screw the engine up putting it in the wrong spot. I saw somewhere saying something about a reverse flush. But i think that was only pertaining to up to the 93 sl series skis.

    Thank you. Ron


  2. #2
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,385
    +1
    1,745
    How long will you be running the engine on the trailer?

    Are you riding in salt water? Or dirty water?

  3. #3
    Quote Originally Posted by K447 View Post
    How long will you be running the engine on the trailer?

    Are you riding in salt water? Or dirty water?

    Ill be doing salt water and some deleware river and its creeks and such. Ill only be running it on trailer for a minute or so. Just long enough to make sure i have no fuel leaks as i just bought the ski and have not had it running.

  4. #4
    Click avatar for tech links/info K447's Avatar
    Join Date
    Jul 2007
    Location
    near Toronto, Canada
    Posts
    39,385
    +1
    1,745
    Quote Originally Posted by Leftwithnoexits View Post
    Ill be doing salt water and some deleware river and its creeks and such. Ill only be running it on trailer for a minute or so. Just long enough to make sure i have no fuel leaks as i just bought the ski and have not had it running.
    Much better to strap it down to the trailer front and rear, then back it down the launch ramp. Run it with jet pump inlet fully submerged for as long as needed to confirm proper operation. Take the seat off to monitor inside the hull with engine running. Apply throttle and steering to test those. Make sure no debris or loose rocks below the jet pump intake.

    Worried about fuel leaks? Have you replaced the fuel hoses with new, new OEM fuel filter and fuel selection valve? If not, do so now. Rebuild the carburetors at the same time, use genuine Mikuni carb rebuild kits.

    New oil filter too.

  5. #5
    Quote Originally Posted by K447 View Post
    Much better to strap it down to the trailer front and rear, then back it down the launch ramp. Run it with jet pump inlet fully submerged for as long as needed to confirm proper operation. Take the seat off to monitor inside the hull with engine running. Apply throttle and steering to test those. Make sure no debris or loose rocks below the jet pump intake.

    Worried about fuel leaks? Have you replaced the fuel hoses with new, new OEM fuel filter and fuel selection valve? If not, do so now. Rebuild the carburetors at the same time, use genuine Mikuni carb rebuild kits.

    New oil filter too.
    Carbs were done just before i got the ski. He also said he did fuel lines as well. Oil pump was taken out.

    will definitely back down the ramp to fully test out. More so just trying to make sure the thing will start and run as i have not had it running yet.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Run time for SHO off hose
    By Flash in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-20-2010, 02:45 AM
  2. took off hose and it was filled with (oilcatchcan topic)
    By 2005cdoorxp in forum 4-Tec Performance
    Replies: 3
    Last Post: 03-16-2010, 02:48 PM
  3. HELP!! Engine stalled while running on hose - what do I do?
    By way2much2do in forum Polaris Open Discussion
    Replies: 7
    Last Post: 06-27-2009, 10:55 PM
  4. where's my coolant running off to?
    By SpeedDiva in forum 4-Tec Performance
    Replies: 6
    Last Post: 06-10-2008, 04:50 PM
  5. battery run off line ?
    By Bone1050 in forum Polaris Open Discussion
    Replies: 3
    Last Post: 09-30-2006, 11:16 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •