Results 1 to 6 of 6
  1. #1
    Lorenzzo's Avatar
    Join Date
    Jul 2013
    Location
    SXM St Martin
    Posts
    15

    2013 fx sho help

    Im having trouble with my fx im not getting any spark and my injector aren't firing crank sensor seems fine i changed it to be sure only other thing i know about is the flywheel generator or what ever that thing is called again lol please help


  2. #2
    CHINE WALKER nicor6's Avatar
    Join Date
    Jun 2014
    Location
    Mahe
    Posts
    376
    +1
    44
    Quote Originally Posted by Lorenzzo View Post
    Im having trouble with my fx im not getting any spark and my injector aren't firing crank sensor seems fine i changed it to be sure only other thing i know about is the flywheel generator or what ever that thing is called again lol please help
    Have you checked if there's any trouble code? have you checked all fuses?

  3. #3
    Lorenzzo's Avatar
    Join Date
    Jul 2013
    Location
    SXM St Martin
    Posts
    15
    All fuses checked and replaced im not getting any codes i can check again to make sure

  4. #4
    CHINE WALKER nicor6's Avatar
    Join Date
    Jun 2014
    Location
    Mahe
    Posts
    376
    +1
    44
    Quote Originally Posted by Lorenzzo View Post
    All fuses checked and replaced im not getting any codes i can check again to make sure
    Please double check just to make sure, It just started to happen? did you do anything before having this problem? sometimes if the throttle body remains slightly open, when cranking the engine you wont get any fuel or spark.. but as you were saying flywheel generator (stator coil) if i remember correctly it will just cut spark not fuel..

  5. #5
    Scottpaige's Avatar
    Join Date
    Jan 2017
    Location
    Newcastle UK
    Posts
    450
    +1
    45
    Quote Originally Posted by Lorenzzo View Post
    Im having trouble with my fx im not getting any spark and my injector aren't firing crank sensor seems fine i changed it to be sure only other thing i know about is the flywheel generator or what ever that thing is called again lol please help
    I know like another user said. I won't start if throttle open in any way.

  6. #6
    Lorenzzo's Avatar
    Join Date
    Jul 2013
    Location
    SXM St Martin
    Posts
    15
    Last thing i did was try to change my starter cluck with no success its possible that i over heated the stator magnet but ill double check everything this afternoon after work

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Intake grate or not to intake grate. 2013 FX SHO
    By fokie in forum Yamaha PWC Performance (4-stroke)
    Replies: 26
    Last Post: 09-16-2018, 12:12 PM
  2. 2013 FX SHO Issue HELP PLEASE
    By Reynolds in forum Yamaha PWC Performance (4-stroke)
    Replies: 11
    Last Post: 08-09-2016, 03:17 PM
  3. newbie buying two 2013 fx sho
    By nick8454 in forum Yamaha Open Discussion
    Replies: 19
    Last Post: 06-22-2013, 02:29 PM
  4. Whats a good ECU for a 2013 FX SHO??
    By fokie in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 02-12-2013, 06:36 AM
  5. 2013 fx sho
    By fokie in forum Yamaha PWC Performance (4-stroke)
    Replies: 5
    Last Post: 01-06-2013, 01:53 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •