Page 1 of 3 1 2 3 LastLast
Results 1 to 10 of 24
  1. #1
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512

    Question People with boost what hose clamps you using??

    People with BOOST what hose clamps are you using? I'd like to add some muscle to my clamp game on the boost side of things...Had my hose between IC and throttle body come off on a wide open run the other day and I'd like something with more clamping power for that area around IC to TB area...Thanks!!

    P.S. - Pics of the clamps and engine areas with them would be great too


  2. #2
    txgp1300r's Avatar
    Join Date
    Apr 2006
    Location
    Dallas , Texas
    Posts
    3,450
    +1
    188
    I use the T-Bolt clamps that Frozen boost sells I also put a very small film of blue rtv on the inside of the hose

  3. +1 by:


  4. #3
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,347
    +1
    304
    T bolts

  5. #4
    YAMAHA POWAAAA !!!!! 1_Fast_SHO's Avatar
    Join Date
    Apr 2010
    Location
    Houston, Texas
    Posts
    3,347
    +1
    304
    Click image for larger version. 

Name:	IMG_2347.jpg 
Views:	107 
Size:	76.4 KB 
ID:	409369

  6. +1 by:


  7. #5
    Chupacobra's Avatar
    Join Date
    Jun 2012
    Location
    Orlando, FL
    Posts
    1,393
    +1
    420
    stock yamaha clamps. this is what and only use even with multiple et27 builds at 9800

    Tbolts are way too wide


  8. #6
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512
    Quote Originally Posted by Chupacobra View Post
    stock yamaha clamps. this is what and only use even with multiple et27 builds at 9800

    Tbolts are way too wide
    You ever double up on the stock clamps? I was thinking of using 2 clamps on certain areas like the TB and IC areas where it's building pressure...I'm surprised you can get away with stock clamps on those types of builds wow...

  9. #7
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512
    Quote Originally Posted by txgp1300r View Post
    I use the T-Bolt clamps that Frozen boost sells I also put a very small film of blue rtv on the inside of the hose
    Good stuff I may experiment with these t bolts...

  10. #8
    Chupacobra's Avatar
    Join Date
    Jun 2012
    Location
    Orlando, FL
    Posts
    1,393
    +1
    420
    there is not enough room to double up clamps

  11. #9
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,430
    +1
    1,766
    I like normal clamps for most things. The fact that the clamp is not cut makes it pretty darn strong.


  12. +1 by:


  13. #10
    lets race.... mikeFZR's Avatar
    Join Date
    Mar 2009
    Location
    MA
    Posts
    4,273
    +1
    275
    Quote Originally Posted by FZeeR View Post
    You ever double up on the stock clamps? I was thinking of using 2 clamps on certain areas like the TB and IC areas where it's building pressure...I'm surprised you can get away with stock clamps on those types of builds wow...
    only place I double up on clamps is on my riva free flow exhaust because there is space for it, and I noticed that with only one clamp some air was escaping.

Page 1 of 3 1 2 3 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2 stroke oil questions..What brand do you use?
    By GeoRXT in forum Yamaha PWC Performance (2-stroke)
    Replies: 54
    Last Post: 08-09-2008, 11:04 AM
  2. What impeller are you using?
    By xlint89 in forum Polaris PWC Performance
    Replies: 35
    Last Post: 10-28-2007, 11:23 AM
  3. What oil are you using?
    By Beagleman62 in forum Kawasaki PWC Performance (4-stroke)
    Replies: 19
    Last Post: 07-11-2007, 01:01 PM
  4. What gps do you use?
    By Brett541 in forum Yamaha PWC Performance (2-stroke)
    Replies: 21
    Last Post: 06-01-2007, 09:19 AM
  5. OPAS Removed, What sponsons are you using?
    By ramnj in forum Sea Doo Open Discussion
    Replies: 25
    Last Post: 04-09-2006, 09:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •