Page 1 of 2 1 2 LastLast
Results 1 to 10 of 13
  1. #1
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    284
    +1
    16

    4tec Idle Surging - Anyone actually find a solution yet?

    Hey guys, I've been putting up with a 1-200 rpm idle surge on my 2003 GTX S/C. It starts at idle persists all the way to the high rpms. I've checked the Idle bypass controller and it seems fine. I can hear/feel it moving when I put the key on. The problem occurs in and out of the water. I've installed new plugs to no avail. I came across multiple threads all over with people who have a similar issue, but nobody ever posts a solution or conclusion. Has anyone out there actually solved this annoying gremlin? I'm hesitant to drop $200 on a new idle bypass valve just to find out it's the TPS or something simple.


  2. #2
    This is how I run a jetski shop in the desert nmpeter's Avatar
    Join Date
    May 2008
    Location
    Elephant Butte New Mexico
    Posts
    7,430
    +1
    1,766
    the idle air valve is 14 years old, it's a precision bit, your options are limited here.

    is it a $200 annoyance?..when the IAV finally craps ( and it will at some point..I've seen em go as much as 700 hours) you can replace it without guilt of blowing alot of money on what i say is an minor annoyance.

  3. #3
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    284
    +1
    16
    Quote Originally Posted by nmpeter View Post
    the idle air valve is 14 years old, it's a precision bit, your options are limited here.

    is it a $200 annoyance?..when the IAV finally craps ( and it will at some point..I've seen em go as much as 700 hours) you can replace it without guilt of blowing alot of money on what i say is an minor annoyance.
    My fear is replacing it and it NOT being the culprit. It's an expensive experiment. I just wonder if there is something else that is known to cause this. I have had this engine completely apart (approximately 70 engine hours ago). It runs good and strong with no issues except this one. It's got a total of 190 or so hours.

  4. #4

    Join Date
    Jun 2016
    Location
    northern nj
    Posts
    49
    Quote Originally Posted by IDoSeaDoo View Post
    Hey guys, I've been putting up with a 1-200 rpm idle surge on my 2003 GTX S/C. It starts at idle persists all the way to the high rpms. I've checked the Idle bypass controller and it seems fine. I can hear/feel it moving when I put the key on. The problem occurs in and out of the water. I've installed new plugs to no avail. I came across multiple threads all over with people who have a similar issue, but nobody ever posts a solution or conclusion. Has anyone out there actually solved this annoying gremlin? I'm hesitant to drop $200 on a new idle bypass valve just to find out it's the TPS or something simple.

    ever figure this out? im having a similar issue. Idles will dip to 1600 then jump to 2200. idle bypass is seized on. Could it be fuel?

  5. #5
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    284
    +1
    16
    Well, I hooked up the BUDS to mine, and it seemed that the pressure sensor on the manifold was fb fluctuating ever so slightly. This was with the engine off. I haven't replaced mine yet, but that's what I'm currently suspecting. I doubt it's fuel because that boat has a new tank and completely fresh fuel, new fuel filters and I verified it gets the correct fuel pressure. I also changed my plugs recently and rebuilt the sc.

  6. #6
    Orlando Shark's Avatar
    Join Date
    Mar 2009
    Location
    Orlando, FL
    Posts
    2,682
    +1
    37
    Try a new Map sensor and clean the Intake manifold temp sensor.

  7. #7
    It was high fuel pressure on mine. An adjustable pressure regulator fixed it.

  8. #8

    Join Date
    Jun 2016
    Location
    northern nj
    Posts
    49
    Quote Originally Posted by IDoSeaDoo View Post
    Well, I hooked up the BUDS to mine, and it seemed that the pressure sensor on the manifold was fb fluctuating ever so slightly. This was with the engine off. I haven't replaced mine yet, but that's what I'm currently suspecting. I doubt it's fuel because that boat has a new tank and completely fresh fuel, new fuel filters and I verified it gets the correct fuel pressure. I also changed my plugs recently and rebuilt the sc.
    Starting to suspect one of the manifold sensors could be the issue for mine as well, mainly because I haven't checked them. I did swap coils, plugs, injectors with a known working ski and the idle surge issue persisted. In the process of diagnosing, I noticed a leaking waterbox. Im going to make a new post about my issues including this leak.

  9. #9
    Having Fun jp1300r's Avatar
    Join Date
    Sep 2005
    Location
    Florida
    Posts
    5,341
    +1
    261
    Quote Originally Posted by zylinderkopf View Post
    Starting to suspect one of the manifold sensors could be the issue for mine as well, mainly because I haven't checked them. I did swap coils, plugs, injectors with a known working ski and the idle surge issue persisted. In the process of diagnosing, I noticed a leaking waterbox. Im going to make a new post about my issues including this leak.
    Waterbox leak. I am betting thats your problem right there.

  10. #10
    IDoSeaDoo's Avatar
    Join Date
    May 2012
    Location
    Davie, FL
    Posts
    284
    +1
    16
    What do you mean? Leaking exhaust or water? I sometimes run my engine with the cover open, and it still surges.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Does anyone actually have a R3 yet?
    By philip_gpr in forum Yamaha PWC Performance (4-stroke)
    Replies: 30
    Last Post: 08-26-2010, 09:23 PM
  2. Idle Surge?
    By wakewhornc in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 10-28-2009, 09:29 PM
  3. question on ported 1300...idle surges after having water in engine...i
    By MJE in forum Yamaha PWC Performance (2-stroke)
    Replies: 1
    Last Post: 07-23-2009, 09:06 AM
  4. 07 RXT surging....anyone?
    By driveumhard in forum 4-Tec Performance
    Replies: 13
    Last Post: 04-03-2008, 09:25 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •