Page 1 of 3 123 LastLast
Results 1 to 10 of 22
  1. #1

    New to me 2005 rxp. Top speed of 58. Wondering where to start.

    I just bought an 05 RXP 215 with 96 hours. It was sitting for the last year and a half. I first took it out and it didn't run well. It blinked sensor and showed the code p1517. It would only do 35-40mph and had a definite misfire. VTS doesn't work, the vts display is blank on the gauges, 7.5 amp fuse is good.

    It only had a few gallons of fuel in it. So I put a bottle of seafoam in it and filled it with 92 octane. Then installed new spark plugs. I was worried that the stock supercharger could have bad ceramic washers in it(I bought it from the second owner and he said it's not been rebuilt) So I took the charge hose off and tried to turn the supercharger. I didn't feel any slip. The impeller turned when the supercharger turned.

    I took it out today and here's what I got. This is from the gauges, not GPS. Full throttle best of 58mph@8100-8200, half to three quarter throttle best of 55mph@7400-8000, lake temp 46, engine temp 60, air temp 61, smooth water in a lake. I've never ridden one of these before, I'm coming from a 96 Sea-Doo GTI. This ski doesn't feel that much better, which means something is definitely wrong.

    My goals for this ski is to ride it stock and have it be reliable, and fun. The only mod I might do is an impeller.

    I'm wondering where to start. Dealer to clear code and tell my ski it's an rxp instead of an rxt? New carbon ring and associated parts? Wear ring and upgraded impeller? Supercharger rebuild from Jerry? Bilge pump?


  2. #2
    Redrockat's Avatar
    Join Date
    May 2015
    Location
    South Africa
    Posts
    258
    +1
    23
    Hello ! Before you put any more time on motor I'd do the s charger ! Then would look at the valves . But first the supercharger . Get the pump in order and it should be running good

  3. +1 by:


  4. #3
    What should I start with in the pump? Should I do any of that while the charger is out? I want to get this ready for the season. And with a wet suit that's any day it's not raining.

  5. #4
    mrsprinkles's Avatar
    Join Date
    Apr 2016
    Location
    Binghamton, NY
    Posts
    295
    +1
    20
    Quote Originally Posted by Hondakilla98 View Post
    What should I start with in the pump? Should I do any of that while the charger is out? I want to get this ready for the season. And with a wet suit that's any day it's not raining.
    Check wear ring gap.

  6. #5

    Join Date
    Jan 2017
    Location
    Turangi, New Zealand
    Posts
    19
    +1
    6
    + 1 what Redrockat said mate, definitely do the S/C and check your wear ring gap, pull the cover and check your valves. 58 is way too sluggish, something must be wrong! My 04 RXP pulls 70 all day long.
    run that tank of fuel out and throw some fresh gas and plugs at it and check the plugs again after a good run, they should tell the story.

  7. #6
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,731
    +1
    97

    New to me 2005 rxp. Top speed of 58. Wondering where to start.

    You mentioned it had a few gallons of fuel in it and had been sitting for a year and a half. Then you added fuel on top of that.

    Was that the fuel from a year and a half ago that you speak of?? If so, there's most of the issue. That's like adding fresh 91 on top of 4 gallons of water. Drain entire tank, new plugs, fresh fuel, see what happens.

  8. +1 by:


  9. #7
    It doesn't feel like the power is the problem now that I put in new plugs and fresh gas. It feels like a car with bad tires. Like you're just spinning the tires and have no traction. It only goes 3mph faster from 1/2-3/4 throttle to wot.

  10. #8
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    Quote Originally Posted by ABBOTT View Post
    You mentioned it had a few gallons of fuel in it and had been sitting for a year and a half. Then you added fuel on top of that.

    Was that the fuel from a year and a half ago that you speak of?? If so, there's most of the issue. That's like adding fresh 91 on top of 4 gallons of water. Drain entire tank, new plugs, fresh fuel, see what happens.

    he said it pulled 8100... it wouldn't do that with horrible gas. It would spit and sputter... as directed... before you waste your season... have charger rebuilt, replace wear ring as it will make rpm but not speed if it's bad. Also check the numbers laser etched on the valves. Bad exhaust valves came in the 05s... read the numbers and get back to us.

  11. #9
    Cannon's Avatar
    Join Date
    Nov 2008
    Location
    Lake Lanier ,Ga
    Posts
    395
    +1
    27
    Your RPMs are fine I am thinking wear ring/ damaged prop.


  12. #10
    ^^^^^ what Cannon said .. no loss in rpm . its making fulling boost. we put put 240 hrs on SC before failed . there is one more possibity. seadoo did a remap on those engines which automically happend with new lanyard programming. Customers complained of loss in performance. Update was suppose to be accompanied by a different part number deto sensor under intake manifold . costs about 40 bucks . start by looking at pump inlet for bashed prop.

  13. +1 by:


Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2012 RXP-X top speed of 60
    By solardude in forum 4-Tec Performance
    Replies: 9
    Last Post: 03-01-2016, 09:55 PM
  2. New member! Swapping 2005 RXP to 2004 GTX SC
    By Schmitt12 in forum 4-Tec Performance
    Replies: 6
    Last Post: 04-25-2015, 08:07 PM
  3. New to me 2005 RXP (red supercharger ?)
    By edge in forum 4-Tec Performance
    Replies: 5
    Last Post: 05-28-2012, 11:20 AM
  4. riddle me this (rxp top speed???)
    By robby212 in forum Sea Doo Open Discussion
    Replies: 12
    Last Post: 03-22-2010, 01:19 PM
  5. New top speed of 73.2 after IC install!!!
    By Turbo Nick in forum 4-Tec Performance
    Replies: 29
    Last Post: 06-26-2007, 08:58 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •