Results 1 to 5 of 5
  1. #1

    2003 GP1300R Speedo Interchange with which XL Model?

    I put a new Cluster Stick on Cover on it about a year ago and havent used ski since... I noticed yesterday that when i press the button it is just mushy like it pushed through inside maybe? Are these Clusters able to be torn apart and serviced ? I have it stuck in damn Kilometers and it wont switch out of the Volts and Kilometers... I would like to see the other functions suck as hours and the misleading MPH. Thanks for any help.

    Also, is the Yamaha Xl cluster a direct bolt on plug and play swap??

    Thanks


  2. #2
    Quote Originally Posted by davdoc0011 View Post
    I put a new Cluster Stick on Cover on it about a year ago and havent used ski since... I noticed yesterday that when i press the button it is just mushy like it pushed through inside maybe? Are these Clusters able to be torn apart and serviced ? I have it stuck in damn Kilometers and it wont switch out of the Volts and Kilometers... I would like to see the other functions suck as hours and the misleading MPH. Thanks for any help.

    Also, is the Yamaha Xl cluster a direct bolt on plug and play swap??

    Thanks

    Bump

  3. #3
    Ramps's Avatar
    Join Date
    Jan 2008
    Location
    Myakka, FL
    Posts
    767
    +1
    35
    When I had my GP1200r I took my cluster off and tried to separate the cover from the body of cluster and broke one of the tabs. Reason I tried was it was sun faded and had a little moisture it seemed inside. Check were it is mounted if your lucky it did just push through and maybe only have to retighten or use one size bigger screw?? It has been a while since I owned my 1200, I am going off memory.... Good Luck....

  4. #4
    powerstroke specialist mikegp's Avatar
    Join Date
    Mar 2011
    Posts
    2,544
    +1
    194
    Quote Originally Posted by davdoc0011 View Post
    I put a new Cluster Stick on Cover on it about a year ago and havent used ski since... I noticed yesterday that when i press the button it is just mushy like it pushed through inside maybe? Are these Clusters able to be torn apart and serviced ? I have it stuck in damn Kilometers and it wont switch out of the Volts and Kilometers... I would like to see the other functions suck as hours and the misleading MPH. Thanks for any help.

    Also, is the Yamaha Xl cluster a direct bolt on plug and play swap??

    Thanks

    the XL don't work 03/08 gpr work

  5. #5
    Quote Originally Posted by mikegp View Post
    the XL don't work 03/08 gpr work
    Thanks for the info!

    It jsut the botton that is mushy feeling and wont let me go through the menu functions

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. WTB 2003 gp1300r crank and 3 pistons and rings in oz
    By gtile04 in forum Yamaha Classifieds
    Replies: 1
    Last Post: 02-05-2010, 08:51 AM
  2. FS 2003 GP1300r in AL
    By Lvnspeed in forum Yamaha 2 Stroke Skis
    Replies: 1
    Last Post: 10-20-2009, 09:09 PM
  3. 2003 gp1300r not running right
    By garathv in forum Yamaha PWC Performance (2-stroke)
    Replies: 13
    Last Post: 01-12-2009, 12:19 PM
  4. 2003 gp1300r hull for sale in md area
    By slow1300 in forum Yamaha Classifieds
    Replies: 6
    Last Post: 07-12-2008, 07:39 PM
  5. 2003 GP1300R Not Running To Well
    By lacfiremx02 in forum Yamaha PWC Performance (2-stroke)
    Replies: 3
    Last Post: 08-17-2006, 10:34 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •