Results 1 to 9 of 9
  1. #1

    Join Date
    Jul 2016
    Location
    Quad cities
    Posts
    73

    4" intake and limp mode?

    Hi everyone ,I had a question my mechanic was telling me he's heard of issues with people installing a 4 inch air intake on their jetski and it going into limp mode bc of too much air and throwing off sensors? is this true has anyone else heard of this? It will be going on a 07 rxp 215.
    Thanks!


  2. #2

    Join Date
    Jul 2016
    Location
    Quad cities
    Posts
    73
    You are also need to get different straps or am I able to run it right above the tank?

  3. #3
    JPR's Avatar
    Join Date
    Mar 2007
    Location
    Down under
    Posts
    959
    +1
    60
    you need a new mechanic.

  4. +1 by:


  5. #4

    Join Date
    Jul 2016
    Location
    Quad cities
    Posts
    73
    That's what I'm thinking cuz that's the first time I've ever heard of that too.. does anyone know if I have to get new gas tank straps on one side or can I run the tube right above the gas tank?

  6. #5
    ncdoo's Avatar
    Join Date
    Nov 2007
    Location
    Eastern NC
    Posts
    1,637
    +1
    175
    How many places are you going to post this question? Your mechanic is full of crap. And no you don't need different straps.

  7. #6

    Join Date
    Jul 2016
    Location
    Quad cities
    Posts
    73
    Maybe a couple different places I'm not sure LOL... and thanks about the strap question.

  8. #7
    JT jpt7779's Avatar
    Join Date
    Jul 2008
    Location
    Pittsburg, Texas Lake Bob Sandlin
    Posts
    3,996
    +1
    768
    Your mechanic just proves, "you can't fix stupid"!


  9. +1 by:


  10. #8
    Tie a knot in each strap and that will take the slack out of it from not having the air box in with it.

  11. +1 by:

    JPR

  12. #9

    Join Date
    Jul 2016
    Location
    Quad cities
    Posts
    73
    I appreciate the help thanks!

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. I also have oil warning and limp mode
    By newskiier in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-19-2011, 07:22 AM
  2. polaris genesis water leak and limp mode help
    By hot83chevy in forum Polaris How To & FAQs
    Replies: 21
    Last Post: 05-12-2011, 11:22 PM
  3. Replies: 19
    Last Post: 09-19-2010, 06:23 AM
  4. Ultra 150 Engine and Limp Mode
    By s0ker in forum Kawasaki PWC Performance (2-stroke)
    Replies: 7
    Last Post: 08-04-2010, 09:36 AM
  5. Simple boost questions for R-12X. Max and "limp mode"
    By obiwan in forum Honda Open Discussion
    Replies: 8
    Last Post: 06-25-2009, 08:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •