Page 1 of 2 1 2 LastLast
Results 1 to 10 of 17
  1. #1
    Sik330ci's Avatar
    Join Date
    Jul 2016
    Location
    NY
    Posts
    157
    +1
    17

    Need some help guys with afr's

    I have a 2013 yamaha fzr
    intake
    ribbon delete
    fizzle
    svho supercharger
    riva retainers
    fuel pressure regulator
    svho injectors
    160 wear ring
    solas deans pitch 13/20
    cooling kit
    deans svho tune to 9450 rpms

    took it out today for the first time and at idle and cruising afr's are 11.6-11.9 which is good... but at WOT it feels like the ski holds back and afr's go up to 13.5 which is no good(lean)... i startet my pressure at 60(where dean told me to put it) i even went to 70 psi of fuel pressure and no change(no rising rate)..... do i need a fuel pump??? Still running stock sho fuel pump. Or is it the map on the ecu? Any help will be appreciated! Thanks!


  2. #2
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512
    You need fuel pump. There's no way a stock SHO pump is supplying enough fuel for a svho wheel at 9400rpm...70psi is wayyy beyond where you should be. Even just switching to a big boy pump on mine staying at stock pressure brought idle afr down a full point.

  3. #3
    raiderx72's Avatar
    Join Date
    Jul 2007
    Location
    Rocky Hill, CT
    Posts
    602
    +1
    64
    Agree I would say fuel pump

  4. #4
    Sik330ci's Avatar
    Join Date
    Jul 2016
    Location
    NY
    Posts
    157
    +1
    17
    Thats exactly what i had in mind!! And even at 7000 rpms the afrs already start going up! I appreciated so much guys!!!

  5. #5
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512
    Quote Originally Posted by Sik330ci View Post
    Thats exactly what i had in mind!! And even at 7000 rpms the afrs already start going up! I appreciated so much guys!!!
    Yea I wouldn't run the ski again until you have proper fueling. Wide open 13.5+ afr will blow your shit up in no time. Keep us posted.

  6. #6
    shhr's Avatar
    Join Date
    May 2005
    Location
    Springfield,TN
    Posts
    2,575
    +1
    327
    So last year you were running 9450 rpm ? In what kind of weather ? What's your limiter set at ? You must keep these boats off the limiter at those RPMs

  7. +1 by:


  8. #7
    Sik330ci's Avatar
    Join Date
    Jul 2016
    Location
    NY
    Posts
    157
    +1
    17
    Will keep you guys updated! Going to order the aeromotive 340 from riva!

  9. #8
    Sik330ci's Avatar
    Join Date
    Jul 2016
    Location
    NY
    Posts
    157
    +1
    17
    My limiter is set at 9450 rpms! Dont know what rpm i can get to due to running lean.... as soon as i WOT the afrs climb right up!

  10. #9
    95.4mph FZR FZeeR's Avatar
    Join Date
    Aug 2014
    Location
    FL
    Posts
    1,890
    +1
    512
    Quote Originally Posted by Sik330ci View Post
    My limiter is set at 9450 rpms! Dont know what rpm i can get to due to running lean.... as soon as i WOT the afrs climb right up!
    Once you get proper fueling you'll be able to see what rpm you turn safely. Running lean really kills rpm too.

  11. #10
    ptscon's Avatar
    Join Date
    Jul 2013
    Location
    Toronto
    Posts
    3,389
    +1
    688
    You're also way rich at idle and cruising, 13.5 would be perfect for RPMs below boost but should be tapering down as boost builds.

    Running rich also kills RPMs, it's a fine line how lean you can run it safely at WOT, definitely not 13.5

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. need some help guys with oil change
    By 2017 fx svho in forum Yamaha PWC Performance (4-stroke)
    Replies: 3
    Last Post: 03-06-2017, 03:05 PM
  2. Need some Help guys!!!
    By ArmyRXP in forum Open Discussion
    Replies: 1
    Last Post: 01-06-2008, 02:21 PM
  3. need some help guys..
    By bigmatt in forum Polaris Open Discussion
    Replies: 15
    Last Post: 05-14-2007, 10:46 PM
  4. need some help guys...
    By minersny in forum Polaris Open Discussion
    Replies: 6
    Last Post: 03-24-2007, 01:00 PM
  5. Need some help guys, Lost 500rpm
    By CRS in forum 4-Tec Performance
    Replies: 13
    Last Post: 05-15-2006, 05:24 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •