Results 1 to 4 of 4
  1. #1

    2006 Aquatrax F-12X.. lost power made loud rattling noise near jet

    So I was out on the lake the other day on my ski.. I was making a rattling noise and I wasn't sure what the problem was.. I kept riding and then went idle speed for about 10min. Well when I tried to speed back up the rattle noise was loud as He!! and then I couldn't get above 5mph.. I had my Gf pull me a little ways back with her waverunner(had mine running whole time) and we stopped for a sec shut them off.. when fired them back up my power was restored back and didn't hear any noise. I took back to dealer as this was a recently purchased ski with 47 hours on it and they said they could find no problems. I haven't taken the ski back out to see if noise is still there but does anyone have any idea what the problem could have been? something like stick stuck in jet or anything? I wonder cause I was still about to go full speed before I lost power but I just had a louder noise. Im gong to take the ski back out soon as I plan on picking it back up from dealer today.

    Thanks in advance

    JMSABO


  2. #2

    Join Date
    Jan 2007
    Location
    Lake Powell, Page, Az
    Posts
    330
    +1
    1
    could have definitely been a stick. that happens a lot on our Lake every season when the spring run off returns. It will reattle so bad you think the ski is going to blow up

  3. #3
    What did you find out?

  4. #4
    red rider's Avatar
    Join Date
    Oct 2006
    Location
    Northridge,California
    Posts
    464
    +1
    11
    Sounds like something is stuck in the intake grate and pump.. grab a flashlight and start investigating..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2006 Honda AquaTrax F-12X Missing between 4000 -5000 RPM's
    By John4762 in forum Honda Open Discussion
    Replies: 2
    Last Post: 08-10-2010, 05:31 PM
  2. Lost Power on '03 GPR1300...HELP!
    By handybuilder in forum Yamaha PWC Performance (2-stroke)
    Replies: 12
    Last Post: 06-10-2007, 07:49 PM
  3. Lost power
    By Boucher525 in forum Yamaha PWC Performance (2-stroke)
    Replies: 2
    Last Post: 03-28-2007, 01:42 AM
  4. Lost power
    By John in forum 4-Tec Performance
    Replies: 19
    Last Post: 08-08-2006, 03:15 PM
  5. 05 rxp lost power
    By 1969camaro-rs in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-10-2005, 08:29 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •