Results 1 to 4 of 4
  1. #1
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    319
    +1
    1

    2016 310X FI light comes on randomly

    Hey guys,

    Hoping you can help me out. My buddies 310X has 54 hours on it, and has been a great ski. Recently the FI light comes on and limits some of the power, but not much. Hes been pulling the key out and resetting it and it takes off again. Sometimes 10 mins, sometimes 30 mins of run time before it comes back on. It started running really rough and then wouldnt idle. We put a fresh set of plugs in today and it runs great again. Ran it for about 20 mins and thought we solved the issue and it came on again. Its idleing smooth and runs great though. Any Idea on where to start or what it could be? Ive read some posts where their power is limited to 3k rpms after the light but this is not the case. Thanks for any tips you guys can give!


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Whenever the F1 comes on pull the lanyard the F 1 will still be flashing and hold the SET and MODE for 2 secs an actual code will come up , look it up in Service manual or tell us ... We'll go from there 👍

  3. #3
    ktyamaha36's Avatar
    Join Date
    Sep 2009
    Location
    Winter Haven,FL
    Posts
    319
    +1
    1
    The code was for theSpeed sensor circuit. The only mods done to this ski are the exhaust filter delete and a R&D speed module. So I assume the R&D box is causing the issue here because I removed it and rode the ski for about 45 mins and got no FI light..... Is anyone else having issues from a speed fooler module?

  4. #4
    Take the time to smile sirbreaksalot's Avatar
    Join Date
    Jun 2007
    Location
    Brisvegas
    Posts
    4,347
    +1
    659
    Quote Originally Posted by ktyamaha36 View Post
    The code was for theSpeed sensor circuit. The only mods done to this ski are the exhaust filter delete and a R&D speed module. So I assume the R&D box is causing the issue here because I removed it and rode the ski for about 45 mins and got no FI light..... Is anyone else having issues from a speed fooler module?
    common problem if not installed correctly.........

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. fi light coming on and cutting boost and fuel 03 r12x
    By koumiss45 in forum Honda Open Discussion
    Replies: 2
    Last Post: 08-07-2010, 01:40 PM
  2. RXP stage II H Temp light coming on
    By MIARider in forum 4-Tec Performance
    Replies: 20
    Last Post: 08-23-2007, 11:42 PM
  3. RXP stage II H Temp light coming on PART II
    By MIARider in forum 4-Tec Performance
    Replies: 18
    Last Post: 08-16-2007, 01:39 AM
  4. 2003 GTX SC oil light comes on but oil level is fine??
    By djbauer in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 07-25-2006, 04:35 PM
  5. Warning light coming on rr ecu
    By Chezzy in forum 4-Tec Performance
    Replies: 7
    Last Post: 04-19-2006, 08:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •