Results 1 to 5 of 5
  1. #1

    Kawasaki 310r loosing power

    Hi all

    Have a Kawasaki 310r jet ski with an scom which has been installed last year.

    i went for a ride with it today and after I tried to run it at full speed, it reaches top speed and then starts loosing power.

    jet ski accelerates normal and only does this after I reach 67mph

    note that a new supercharger belt has been installed as the old one broke last week.

    Am assuming maybe a water leak which is causing the belt to slip but there is not too much water in the hull

    thanks in advance for your help


  2. #2
    Fat Man, Little Boat Region8Ultra250X's Avatar
    Join Date
    Jun 2007
    Location
    Jersey
    Posts
    5,636
    +1
    184
    Quote Originally Posted by Cosmaniac23 View Post
    Hi all

    Have a Kawasaki 310r jet ski with an scom which has been installed last year.

    i went for a ride with it today and after I tried to run it at full speed, it reaches top speed and then starts loosing power.

    jet ski accelerates normal and only does this after I reach 67mph

    note that a new supercharger belt has been installed as the old one broke last week.

    Am assuming maybe a water leak which is causing the belt to slip but there is not too much water in the hull

    thanks in advance for your help

    proper tension probably wasn't set when the belt was reinstalled. that is probably what is causing the belt to slip.

  3. #3

    Join Date
    Jan 2016
    Posts
    1,529
    +1
    306
    310 should have the automatic tensioner.... make sure its not froze and moves freely, Eliminate the water leak. 2 easy ones to start off with

  4. #4

    Join Date
    Jan 2007
    Location
    Kansas
    Posts
    403
    +1
    14
    I was thinking the manual says not to let that tensioner relax when removing the belt, or it can be damaged, don't understand why but that's what is says. There is a tool to hold it in the compressed position...

  5. #5
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Quote Originally Posted by kansasgpr View Post
    I There is a tool to hold it in the compressed position...
    Great tool though you have to get it on a vise right away , just a simple bench vise compresses the spring and then put on the bracket tool makes a seized tensioner or trouble compressing the dummy nut while changing a belt so easy...

    Some new skis come having the bracket tool compressed on the spring ready to be dropped down or come without it ... Gonna have to buy the whole tensioner to get the bracket..

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki 250 x Ultra 2007 loosing power the applying full throttle
    By VladG in forum Kawasaki PWC Performance (4-stroke)
    Replies: 10
    Last Post: 09-08-2015, 05:28 PM
  2. waverunner loosing power
    By LaRubia in forum Yamaha Old School Skis
    Replies: 3
    Last Post: 07-20-2008, 11:13 AM
  3. waverunner loosing power
    By LaRubia in forum Yamaha How To & FAQs
    Replies: 2
    Last Post: 07-20-2008, 07:45 AM
  4. 1999 slx 1050 looses power
    By Pauly in forum Polaris Open Discussion
    Replies: 4
    Last Post: 02-15-2008, 07:10 AM
  5. Kawasaki General Engine Power (PS vs HP)
    By jscottmsc in forum Kawasaki Tech Tips and Info
    Replies: 2
    Last Post: 09-27-2006, 01:48 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •