Results 1 to 7 of 7
  1. #1

    Helppp needed please people

    Got a 2008 rxpx 255
    Having trouble with ski powering down when I pull the lanyard off
    Ski powers off as normal but give it 30-40secs and the fuel pump primes and cluster powers up with out the lanyard being connected
    But can not start the ski

    Have check the loom and tested the dess post but still seems like dess post is causing all my problems

    I can unplug the loom to the handlebars and all power shuts off

    Some advice would be highly appreciated


  2. #2
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    Most likely Dess post. Yes unplug the harness and see what happens.

  3. +1 by:


  4. #3

    Join Date
    Apr 2016
    Location
    Hockeytown
    Posts
    519
    +1
    123
    Without seeing it, id guess its your post or you have a sticky relay. I dont suppose you have a buds or a candoo?

  5. #4
    I've replaced the main relay , I unplug the harness to the dess post and it all powers down as it should

    I don't have buds or candoo

  6. #5
    Kmorningstar_rxp's Avatar
    Join Date
    Feb 2015
    Location
    Port orange, Fla
    Posts
    1,671
    +1
    166
    If it powers down when you unplug dess post, then your post is sticking/ bad.

  7. #6
    Okay will get a replacement cheers

  8. #7
    I would try disconnecting starter switch.. see if continues. Then try disconnecting lanyard post harness and see if problem persists. "Swap tronics" is an expensive guessing game.

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Replies: 4
    Last Post: 09-12-2009, 08:55 PM
  2. Research Info needed, please help
    By shawn alladio in forum Sea Doo Open Discussion
    Replies: 17
    Last Post: 01-04-2008, 03:41 PM
  3. help needed please...
    By gprdean in forum Yamaha PWC Performance (2-stroke)
    Replies: 8
    Last Post: 07-21-2007, 05:25 PM
  4. Help needed please...
    By mkersey24 in forum Sea Doo Open Discussion
    Replies: 3
    Last Post: 05-21-2007, 07:52 PM
  5. 1300 cylinder information needed..please.
    By HopatcongGPR in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-25-2006, 09:54 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •