Results 1 to 9 of 9
  1. #1
    stage2pc's Avatar
    Join Date
    May 2015
    Location
    DOWN HERE
    Posts
    81
    +1
    11

    Arp Bolt upgrade on 300TX

    Has anyone ever preformed the ARP bolt upgrade on a 300 TX while leaving motor in hull? Looks like a PITA but I figure I will ask anyway. Thanks in advance.


  2. #2
    connorrxp's Avatar
    Join Date
    Dec 2014
    Location
    ontario
    Posts
    920
    +1
    132
    If it's the same as the 260's (which I'm 99% sure it is) all you need to do to get in there is remove the left engine mount to get the pto off. BUT holly shit don't do it, even if you suck all the oil out of the motor untill it's dry about 2 cups of oil will still drain out of it into your hull and you'll have a hell of a time cleaning it up. By the time you remove the engine mount you may as well just take out the other 2 mounts and remove the wiring harness. Get a buddy to help you lift the motor out no need for an engine lift or anything. Sit the engine on a bench and have at it!

  3. #3

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,096
    +1
    834
    Don't remove your motor mounts unless you want to align your motor.

  4. #4
    connorrxp's Avatar
    Join Date
    Dec 2014
    Location
    ontario
    Posts
    920
    +1
    132
    Quote Originally Posted by DinoMite View Post
    Don't remove your motor mounts unless you want to align your motor.
    I'd say aligning the engine would be easier than cleaning up the shit show that would insue after cracking the pto off the engine inside the hull hahaI look at is as killing two birds at once, get the bolts in there and fix the factory alignment while you're at it cuz it's usually fucked

  5. #5

    Join Date
    May 2010
    Location
    Jax,FL
    Posts
    4,096
    +1
    834
    Quote Originally Posted by connorrxp View Post
    I'd say aligning the engine would be easier than cleaning up the shit show that would insue after cracking the pto off the engine inside the hull hahaI look at is as killing two birds at once, get the bolts in there and fix the factory alignment while you're at it cuz it's usually fucked
    Both my 300s get almost zero water in them unlike every 260 I've had. I think partially do to the bigger hat.

    Yah i,would just unbolt the motor from the mounts and just pull the motor...it's easy and way easier to work on. Your alignment shouldn't change based on the several times I've done it. But i always check the alignment before and after I pull the motor so I know nothing has changed.

  6. #6
    stage2pc's Avatar
    Join Date
    May 2015
    Location
    DOWN HERE
    Posts
    81
    +1
    11
    Thanks guys. I get zero water in my hull even when it sits in the lake overnight. I can do thru hull while its out. Just wanted to get some input before its time for stage 3. If I wait it will be back at stage 0.

  7. #7
    cyrillefrenchy's Avatar
    Join Date
    Dec 2007
    Location
    st pete beach florida
    Posts
    424
    +1
    26
    i have done a few 260 flywheel bolts without spilling any oil in bilge, just suck the most oil you can, drop the font trailer down to the ground and raise the back of the ski with a jack to have the rear up, put a big rag under the engine and take pto cover off, you may loose a coupe of oil drops, that's all.

  8. #8
    Bob 1tommygunner1927's Avatar
    Join Date
    Apr 2007
    Location
    Houston, Texas
    Posts
    7,276
    +1
    1,299
    A few layered sheets of "pig mat" under the engine will soak up any oil drippings from PTO cover removal.

    https://www.amazon.com/New-Pig-Unive.../dp/B004I665XS

  9. #9

    Join Date
    May 2016
    Location
    Seminole FL
    Posts
    594
    +1
    42
    Cryille what happen to mine then? Lol it must have rained that day and oil must have been falling from sky......

    I just left that in there and next time I took it out it disappeared it was like a magic trick

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. What Upgrades on a 2000 RX
    By dubzrx in forum 2-Stroke Performance
    Replies: 12
    Last Post: 06-23-2008, 08:03 PM
  2. xlt1200 pump shoe bolts snapped on removal
    By 1200racer27 in forum Yamaha PWC Performance (2-stroke)
    Replies: 0
    Last Post: 06-15-2008, 11:43 AM
  3. ecu upgrade on GTX
    By skoepp in forum 4-Tec Performance
    Replies: 1
    Last Post: 03-02-2008, 09:25 PM
  4. upgrade on my skii
    By andy95'slx780 in forum Polaris Open Discussion
    Replies: 18
    Last Post: 02-24-2008, 11:40 AM
  5. Fuel system upgrade on SL750????
    By Wetracer in forum Polaris How To & FAQs
    Replies: 9
    Last Post: 01-18-2007, 03:01 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •