Results 1 to 2 of 2
  1. #1

    Speedometer reads 0

    Hello,

    I just purchased a 2016 Kawasaki 310 SE. I bought it used, and within an hour of use my speedometer stopped working. It displays zero regardless of speed. Anyone experienced anything similar? thanks in advance.
    Last edited by yadirayadira; 02-12-2017 at 09:43 PM.


  2. #2
    "just sayin".. jetdave56's Avatar
    Join Date
    Nov 2008
    Location
    JERSEY SHORE
    Posts
    4,522
    +1
    623
    Check the black paddle wheel on the rideplate probably a rock stopping it from spinning . Start the ski and go behind and spin it and look at the speedometer on dash...

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2015 VXR Speedometer Reading Incorrectly
    By ocod in forum Yamaha PWC Performance (4-stroke)
    Replies: 49
    Last Post: 08-31-2017, 06:36 PM
  2. 2005 Seadoo RXT 215 SPEEDOMETER READING INCORRECTLY
    By tigerman in forum Sea Doo Open Discussion
    Replies: 4
    Last Post: 05-20-2014, 03:50 PM
  3. Replies: 31
    Last Post: 05-02-2012, 10:30 AM
  4. Speedometer Reading
    By GTXDI in forum 2-Stroke Performance
    Replies: 3
    Last Post: 05-28-2010, 08:56 PM
  5. Speedometer reading 0 mph
    By jtmajors in forum Kawasaki PWC Performance (4-stroke)
    Replies: 6
    Last Post: 06-09-2009, 10:55 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •