Page 1 of 3 123 LastLast
Results 1 to 10 of 25
  1. #1
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,742
    +1
    1,052

    Anyone running a turbo 300!!

    Hey guys . I just wanted to let everyone know that if you are running a turbo on a new 300 ski or if you are building one that you need to leave the stock pump washer in place . DO NOT use the washer that comes with the riva 300 open loop kit ! Below is stock that you MUST keep in place Click image for larger version. 

Name:	IMG_9606.JPG 
Views:	118 
Size:	174.0 KB 
ID:	406945



    This is the riva Click image for larger version. 

Name:	IMG_9605.JPG 
Views:	117 
Size:	235.5 KB 
ID:	406946

    That's all I got! Good talk !


  2. #2
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,216
    +1
    235
    The yellow one looks like the one my 2006 215 had more restricted flow , I also ended up opening it up more .

  3. #3
    DR2006RXP's Avatar
    Join Date
    Dec 2012
    Location
    Earth
    Posts
    3,216
    +1
    235
    I think they used a smaller one because they was blowing hoses with the stock one vs the smaller one less flow thus less pressure .

  4. #4
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,742
    +1
    1,052
    Ya this was sort of a surprise so I wanted to let everyone know in case they didn't look at the oem when they remove it

  5. #5
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,742
    +1
    1,052
    Quote Originally Posted by DR2006RXP View Post
    I think they used a smaller one because they was blowing hoses with the stock one vs the smaller one less flow thus less pressure .
    Could be. Either way it's not enough water for a turbo so it's something people will have to do and monitor if they go big . Most people who jump to turbo use better hose clamps anyway

  6. #6
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    781
    Quote Originally Posted by seadoo02xp View Post
    DO NOT use the washer that comes with the riva 300 open loop kit ! Below is stock that you MUST keep in place
    What size is the OEM washer? (ID)

  7. #7
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,742
    +1
    1,052
    Quote Originally Posted by Sanfish View Post
    What size is the OEM washer? (ID)
    I wouldn't have posted this if I wasn't absolutely sure . It's adequate cooling for a supercharged ski but not for the added heat of a turbo setup . I just didn't want to see people burning down there skis .

  8. #8
    GRF + DashPac:) seadoo02xp's Avatar
    Join Date
    Apr 2005
    Location
    MO
    Posts
    4,742
    +1
    1,052
    Oem is 11.8

  9. #9
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    781
    I'm starting to think the main reason why the 300 kits now use a disk in place of an actual thermostat is due hoses popping off.

  10. +1 by:


  11. #10
    Quote Originally Posted by seadoo02xp View Post
    Hey guys . I just wanted to let everyone know that if you are running a turbo on a new 300 ski or if you are building one that you need to leave the stock pump washer in place . DO NOT use the washer that comes with the riva 300 open loop kit ! Below is stock that you MUST keep in place Click image for larger version. 

Name:	IMG_9606.JPG 
Views:	118 
Size:	174.0 KB 
ID:	406945



    This is the riva Click image for larger version. 

Name:	IMG_9605.JPG 
Views:	117 
Size:	235.5 KB 
ID:	406946

    That's all I got! Good talk !
    I have mine drilled out so far it looks like I have just the rubber peice in it.

Page 1 of 3 123 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Has anyone run a Sea do RXP 300 recently?
    By Phil in forum Yamaha PWC Performance (4-stroke)
    Replies: 269
    Last Post: 05-21-2017, 09:31 PM
  2. Does anyone run BG44K in their 300/310 skis?
    By SSGViper in forum Kawasaki How To & FAQs
    Replies: 3
    Last Post: 09-08-2016, 08:02 PM
  3. Is anyone running the 142 wheel on a 300 TX/PX
    By Phishphan1995 in forum 4-Tec Performance
    Replies: 5
    Last Post: 07-28-2016, 06:04 AM
  4. Haw anyone run up against a Sea Doo 300 recently?
    By Phil in forum Kawasaki How To & FAQs
    Replies: 9
    Last Post: 03-28-2016, 03:07 PM
  5. Replies: 5
    Last Post: 07-10-2011, 12:02 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •