Page 1 of 2 1 2 LastLast
Results 1 to 10 of 19

Thread: 14 Rxpx issue

  1. #1
    HaLLiS's Avatar
    Join Date
    Jul 2006
    Location
    New Zealand
    Posts
    238
    +1
    2

    14 Rxpx issue

    Sup fellas,

    Got a small but annoying issue on my 14 px with only 14 hours on it.
    After about 15mins of driving round in the chop the ski gets what sounds like a crack/creak noise each time its hits a wave. Only started happening after I pulled the battery cage out to recharge it but everything's back in solid. Weirdest part is that it only comes from the right front side. Anyone have similar issue?


  2. #2
    maybe you retained the battery back to its cage and u tighten it but,

    did u consider the plastic panel or maybe the bouncy foam hitting something below it???

    take the panels out or tighten them right and check the front compartment then give it a try!!

    Good luck

  3. #3
    HaLLiS's Avatar
    Join Date
    Jul 2006
    Location
    New Zealand
    Posts
    238
    +1
    2
    Are you talking about the 2 panels that shield the battery compartment? It seems to me that all the bolts that were removed are tightened to the limit ( the 2 big bolts either side of the battery cage )
    The noise is quite loud so cant imagine it would be the black foam stuff causing it?

  4. #4
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,731
    +1
    97
    Did you leave a screwdriver or socket wrench in the hull that's now bouncing around?

  5. #5
    HaLLiS's Avatar
    Join Date
    Jul 2006
    Location
    New Zealand
    Posts
    238
    +1
    2
    Quote Originally Posted by ABBOTT View Post
    Did you leave a screwdriver or socket wrench in the hull that's now bouncing around?
    I wish! Does sound like something eventually loosens after awhile and starts to make the noise..

  6. #6
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,731
    +1
    97

    14 Rxpx issue

    Is it so loud that you "feel" it in the steering as well or is it just the noise only. And is your Waterbox & Intercooler strapped properly?

  7. #7
    Sanfish's Avatar
    Join Date
    Jun 2014
    Location
    S/E Florida
    Posts
    2,540
    +1
    780
    Your muffler bearings are loose.

  8. #8
    HaLLiS's Avatar
    Join Date
    Jul 2006
    Location
    New Zealand
    Posts
    238
    +1
    2
    Quote Originally Posted by Sanfish View Post
    Your muffler bearings are loose.
    Ok how would i go about fixing that? Im not mech savy when it comes to jetskis... also would that cause the noise coming from the front right hand side? Thought the muffler would be in the back of the ski?

  9. +1 by:


  10. #9
    HaLLiS's Avatar
    Join Date
    Jul 2006
    Location
    New Zealand
    Posts
    238
    +1
    2
    Quote Originally Posted by ABBOTT View Post
    Is it so loud that you "feel" it in the steering as well or is it just the noise only. And is your Waterbox & Intercooler strapped properly?
    Just the noise and im not sure about it being strapped properly, do i need to pull anything out to do that?

  11. #10
    ABBOTT's Avatar
    Join Date
    Jul 2005
    Location
    Birmingham, AL / Lay Lake
    Posts
    3,731
    +1
    97
    If you haven't messed with it then it's probably strapped correctly. The intercooler probably has two straps and the Waterbox should have 1.

    I just envisioned every bounce from a wake creating a bounce of one of those two items in the rear (if not strapped correctly / or not at all). They are heavy enough to create a nice bang.
    But you mentioned the front right side so I'm truly at a loss as to what that could be.
    Surely the gas tank is strapped in too I would hope. If not, then it's very possible that when under half a tank that it's floating up and down (this would be rare I suspect).

    Strange. Hope the hull isn't separating (top deck from lower deck), but you'd have a bunch of water in the hull if that were the case.

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. No removable front storage bin on 14 RXPX?
    By abmobil in forum Sea Doo Open Discussion
    Replies: 10
    Last Post: 06-30-2014, 06:26 AM
  2. 2012-14 RXPX seat covers
    By naplesrxp in forum 4-Tec Performance
    Replies: 5
    Last Post: 03-26-2014, 06:34 AM
  3. 14 RXPX quote.
    By abmobil in forum Sea Doo Open Discussion
    Replies: 6
    Last Post: 02-26-2014, 01:38 PM
  4. FS - Parts Seadoo centre carbon 2012-14 rxpx seat
    By tweeker in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 02-05-2014, 07:24 PM
  5. FS - Parts Fs: 12-14 rxpx complete riva power filter kit like new
    By dpracing in forum Sea Doo Classifieds
    Replies: 2
    Last Post: 02-05-2014, 07:32 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •