Results 1 to 7 of 7
  1. #1
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2

    Yamaha fx sho problem

    Help needed had a torn throttle dampner replaced it. Ski dint start took ages finally got it going but idled to high blimped throttle and still to high. So i took manifold off again to make sure nothing was stuck. Put it back together again wont start all plugged in right and getting plenty of fuel pressure ???? Problem why doesnt it start and why does it idle to high ???


  2. #2
    Scottpaige's Avatar
    Join Date
    Jan 2017
    Location
    Newcastle UK
    Posts
    451
    +1
    45
    Normally I'd say being hard to start an engine would be a fuel issue. Is it just turning over for a long time
    ? Or is it trying to fire and eventually pick up enough to start?

  3. #3
    Scottpaige's Avatar
    Join Date
    Jan 2017
    Location
    Newcastle UK
    Posts
    451
    +1
    45
    The problem being with most modern ski's (I have 2013 fx sho). You would need a diagnostic plug in by someone and will tell you yr issue straight away.

    No throttle cable on these you may already know so that so nothing to manually ajust.

  4. #4
    take a look at the spark plugs.

  5. #5
    Site Admin Green Hulk's Avatar
    Join Date
    Apr 2005
    Location
    Morgan City, LA
    Posts
    36,759
    +1
    2,707
    Quote Originally Posted by syk03t View Post
    Help needed had a torn throttle dampner replaced it. Ski dint start took ages finally got it going but idled to high blimped throttle and still to high. So i took manifold off again to make sure nothing was stuck. Put it back together again wont start all plugged in right and getting plenty of fuel pressure ???? Problem why doesnt it start and why does it idle to high ???
    If the engine is hard to start and the engine is revving high then you likely have a vacuum leak. Go over all your work and make sure all was done properly.

  6. +1 by:


  7. #6
    syk03t's Avatar
    Join Date
    Jun 2012
    Location
    AUSTRALIA-sydney
    Posts
    213
    +1
    2
    Everything checked over 3 times its getting plenty of fuel. I applied head to get those shitty dampner bolts out as they where corroded and did my head in. Im guessing tps sensor is stuffed ?,

  8. #7
    Scottpaige's Avatar
    Join Date
    Jan 2017
    Location
    Newcastle UK
    Posts
    451
    +1
    45
    You had any luck?

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. 2013 yamaha fx sho rocker cover problem
    By Scottpaige in forum Yamaha PWC Performance (4-stroke)
    Replies: 7
    Last Post: 01-25-2017, 08:33 PM
  2. Wanted: Yamaha FX SHO WaveRunner Engine (1.8L)
    By craigs in forum Yamaha PWC Performance (4-stroke)
    Replies: 13
    Last Post: 02-15-2010, 05:17 AM
  3. 2008 Fx Sho Problems?
    By DOERUN in forum Yamaha PWC Performance (4-stroke)
    Replies: 19
    Last Post: 08-10-2008, 11:16 PM
  4. Yamaha FX SHO after Kawi 15F
    By Jack Bauer On 15F in forum Yamaha PWC Performance (4-stroke)
    Replies: 12
    Last Post: 05-25-2008, 07:13 PM
  5. yamaha fx sho
    By bikerstyle in forum Yamaha PWC Performance (4-stroke)
    Replies: 10
    Last Post: 11-01-2007, 09:57 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •