Results 1 to 7 of 7
  1. #1

    2007 STX 12F won't start

    Jet ski cranks over just fine, but won't start. I wait 10 minutes and then it starts just fine. Been this way for 5 years. But last weekend it wouldn't start at all and I had to tow out. I tried to start it over and over until the battery died. Tried booster battery until it died. Took it home and recharged the battery and it started up just fine. WTF.

    What could be causing this intermittent problem?

    Ideas:
    Battery - nope. I've had several batteries over 5 years. Besides, the engine cranks over just fine.
    Fuel pump - nope. If the fuel pump was faulty, it would die while riding and it has never done that.

    Anything else that could be causing it to not start but still allowing it to ride fine?

    Thanks


  2. #2
    I'd rather be jet skiing Saltwater n Premix's Avatar
    Join Date
    Jul 2010
    Location
    Fort Worth, TX
    Posts
    534
    +1
    52
    Does it have spark when this happens?

    I don't like to guess blindly although I'm about to but I'm thinking that sounds like a crankshaft position sensor going bad.

  3. #3
    Quote Originally Posted by Saltwater n Premix View Post
    Does it have spark when this happens?

    I don't like to guess blindly although I'm about to but I'm thinking that sounds like a crankshaft position sensor going bad.
    Would this affect only the start and not while it's running?

  4. #4
    I'd rather be jet skiing Saltwater n Premix's Avatar
    Join Date
    Jul 2010
    Location
    Fort Worth, TX
    Posts
    534
    +1
    52
    Technically a no crankshaft signal condition would cause most engines to shut off if it happened while running. But sensors are sometimes "funny" about when they decide to work or not.

    Check if it has spark next time it won't start, then we can help you troubleshoot it more accurately

  5. #5
    boudin's Avatar
    Join Date
    Oct 2009
    Location
    Lake Livingston, TX
    Posts
    637
    +1
    69
    Is it after the ski has been running for a while? Could be the hot start issue, but I've only seen that on 15Fs. Could be on 12Fs too. Search for it.

    Next time it happens, pour cool water on the exhaust temp sensor that's on the top of the exhaust manifold.

    -Greg
    Attached Thumbnails Attached Thumbnails Click image for larger version. 

Name:	15F Exhaust Manifold.png 
Views:	54 
Size:	1.40 MB 
ID:	406120  

  6. #6

    Join Date
    May 2008
    Location
    Sweetwater
    Posts
    963
    +1
    152
    Start with this thread first:
    http://www.greenhulk.net/forums/showthread.php?t=186939

    After you have checked all that then you want to check the hot start issue as they stated above. You can do the water trick however the best way is to have a 100k resistor on hand when it's being bad, then unplug the sensor connector towards the rear of the engine by the valve cover. Then add a 100k Resistor into the ECU side of the plug and see if it starts. If it does then a fella named spades here came up with a neat little trick you can search. But basically it's a momentary switch that will add that resistance into the circuit when it happens, and when you let the switch go it will go back to the normal configuration. It's simple to wire up, did it on my 12F and that fixed the annoying issue..

  7. #7
    Quote Originally Posted by boudin View Post
    Is it after the ski has been running for a while? Could be the hot start issue, but I've only seen that on 15Fs. Could be on 12Fs too. Search for it.

    Next time it happens, pour cool water on the exhaust temp sensor that's on the top of the exhaust manifold.

    -Greg
    Awesome, thanks

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Kawasaki STX-12F Won't Start, FI CAAg (CAA9) error code
    By CMoore_kawasaki in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 07-26-2016, 08:11 PM
  2. 2007 stx 12f engine races on start up
    By hesitate in forum Kawasaki How To & FAQs
    Replies: 4
    Last Post: 11-22-2013, 05:12 PM
  3. 2007 stx 12f engine races on start up
    By hesitate in forum Kawasaki How To & FAQs
    Replies: 0
    Last Post: 11-21-2013, 04:09 PM
  4. Wanted: 2007 stx 12f Service Manual
    By matrixman16 in forum Kawasaki Classifieds
    Replies: 2
    Last Post: 08-04-2009, 09:42 PM
  5. 2003 Kawasaki STX 12F Won't Idle
    By P47 in forum Kawasaki Open Discussion
    Replies: 0
    Last Post: 06-04-2008, 08:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •