Page 1 of 2 1 2 LastLast
Results 1 to 10 of 16
  1. #1

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12

    RPM Drop (RXT-X 260)... Any ideas??

    Hi Guys,

    My ski used to top out at 7750 RPM... I then rebuilt the SC, and now after the rebuild it sits at 7540...

    Any suggestions??

    The only other change could be a worn wear ring (as I did a few surf launches before I noticed the RPM drop)... But other than the surf launches and rebuilt SC, nothing else has changed...

    Any possible culprits? Could the ECU drop the REV limiter because the SC maintenance light is not yet cleared?

    Thanks


  2. #2
    Redrockat's Avatar
    Join Date
    May 2015
    Location
    South Africa
    Posts
    258
    +1
    23
    No the ecu will not . Also a worn wearing will cause the rpms to pick up ...

  3. #3
    Redrockat's Avatar
    Join Date
    May 2015
    Location
    South Africa
    Posts
    258
    +1
    23

    RPM Drop (RXT-X 260)... Any ideas??

    Before s/c work it was ok ? After s/c work not ? ...........
    Could be a leaky exhaust

  4. #4
    Greggpru's Avatar
    Join Date
    Sep 2015
    Location
    Nj
    Posts
    1,516
    +1
    133
    What did you set the slip to ?Pull the charger and recheck slip , then check for boost leak ,and exhaust as Redrockat said did you hit 7750 after the rebuild at all ?

  5. #5
    EVN81's Avatar
    Join Date
    Jul 2013
    Location
    Terschelling - the Netherlands
    Posts
    483
    +1
    42
    Check your IC as well, if you still have the stock one! From 2011 and up the were very prone to leak. Water ingestion will also drop RPMīs.

    Take of hose from IC to TB and rev it up when hooked up to the hose.

    If riding salt, you can check for salt build up inside as well.

    Also you say even before rebuild you were only doing 7750? With stock ECU with stock impeller it should be 8040

  6. #6

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12
    Quote Originally Posted by Redrockat View Post
    Before s/c work it was ok ? After s/c work not ? ...........
    Could be a leaky exhaust
    Will check exhaust thanks

  7. #7

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12
    Quote Originally Posted by Greggpru View Post
    What did you set the slip to ?Pull the charger and recheck slip , then check for boost leak ,and exhaust as Redrockat said did you hit 7750 after the rebuild at all ?
    During the rebuilt, I oiled clutches (as per instructions), and after assembly, I rotated the shaft about 10 to 20 times (with clutches slipping)... And then I checked the slip... It was within spec...

    I never got to 7750 after the SC no

  8. #8

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12
    Quote Originally Posted by EVN81 View Post
    Check your IC as well, if you still have the stock one! From 2011 and up the were very prone to leak. Water ingestion will also drop RPMīs.

    Take of hose from IC to TB and rev it up when hooked up to the hose.

    If riding salt, you can check for salt build up inside as well.

    Also you say even before rebuild you were only doing 7750? With stock ECU with stock impeller it should be 8040
    I installed a Fizzle cooler last year... So I'm sure the IC is fine... But I can re-check.

    The 7750 was done at altitude (1430m)... I'm not sure what it was at sea... I only use the ski at the coast about once a year... The rest of the time it's used inland at altitude.

  9. #9

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12
    My top end speed (at altitude) also dropped from 104 km/h to 94km/h.


  10. #10

    Join Date
    Aug 2015
    Location
    South Africa
    Posts
    169
    +1
    12
    Oh... And what is the best way to check for a leak on the exhaust connection ??

Page 1 of 2 1 2 LastLast

Thread Information

Users Browsing this Thread

There are currently 1 users browsing this thread. (0 members and 1 guests)

Similar Threads

  1. Change paint of my RXP 260 - any ideas? stage 3
    By sebastian.pl in forum Sea Doo Build Threads
    Replies: 3
    Last Post: 10-06-2013, 12:49 PM
  2. Fueling help - Les Cooke ECU 8800 RPM for RXT-X 260
    By haapiti007 in forum 4-Tec Performance
    Replies: 26
    Last Post: 03-04-2012, 03:27 AM
  3. 05 RXT major problems any ideas
    By wardie.84 in forum 4-Tec Performance
    Replies: 1
    Last Post: 09-11-2010, 04:02 PM
  4. I need to get my RPM's up-Any ideas.
    By Mongoose in forum Yamaha Old School Skis
    Replies: 28
    Last Post: 04-27-2007, 05:12 PM
  5. Lost 200 RPM's Any Ideas???
    By somefun in forum 4-Tec Performance
    Replies: 4
    Last Post: 07-10-2006, 04:59 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •